2

I'm trying to load around 6000 shapefiles (all the postcodes for a city) into GeoDa but it crashes everytime ("OpenGeoDa.exe has stopped working"). Their troubleshooting page details this problem but I've not been able to resolve the issue, as stated here: http://geodacenter.asu.edu/node/404#load

I've tried to code a new id field in Arcmap but that did not work (was I right in recoding the new ID variable as a short integer?).

I then tried in Arcmap to see if the field names were the problem. I cleaned up most of them up, making them shorter and removing underscores. However, I have been unable to change 5 of the fields (could they be read only?) and the names are over 30 characters long.

Could this be the problem?

Please see the screen grab below for an overview of my data and the length of one of the field names.

enter image description here

Screen grab number 2. Note: I reduced the number of fields to 5 and only selected a few polygons to see if size was the issue. The GeoDa error message on the right is displayed (still the same message).

enter image description here

  • 3
    Did you change the field names or just their aliases? The dBase field names used with shapefiles can't exceed 10 characters. – Vince Jan 10 '14 at 18:38
  • I think for the first few columns Vince, I just changed the aliases. I was struggling on how to change the field name for those first few columns. Can you advise me on how to change their actual names please? Thanks! – Thirst for Knowledge Jan 11 '14 at 10:16
  • There is no such thing as a "read only" field in a shapefile. However, the way in which ArcGIS presents the attributes to you differs slightly from how they are physically stored. For instance, there is no field actually named "shape" in the shapefile, so there is nothing to change in that regard. Have you ever successfully loaded a shapefile into GeoDa or is this your first attempt? – whuber Jan 11 '14 at 15:22
  • 1
    Please see the second screen grab I added to the original query above. Yes, I have successfully loaded data into GeoDa previously. Even when I reduced this data to a few polygons with a few fields (including the additional unique ID), GeoDa still fails to load. Any further ideas please? Thanks! – Thirst for Knowledge Jan 12 '14 at 14:55
2

The polygon type saved in Arcmap was 'Polygon ZM'. I had to change this to to just 'Polygon' by:

Opening the toolbox window, right clicking on on arctoolbox, environments, general settings, and then disabling the z values / m values. I then went to data management tools, features, copy features. This preserved the existing attributes but produced polygons GeoDa could read.

| improve this answer | |
-1

If you have ArcGIS 10 or newer, you can rename Shapefile fields using Catalog. Right-click a shapefile, properties, fields.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.