0

I've noticed that only in chrome my GeoExt app crush when I open many layers. If I resize the window , the layout seems to look good , once I resize to bigger screen , it mess again.

The app code didn't change for long time , it doesn't happen on old laptop with chrome version 27 it only happens on 2 stronger desktops with latest chrome version.

UPDATE

I've found out that commenting the following CSS in openlayers resolve the problem , Any idea why ?

  /**
 * Animations
 */

      .olLayerGrid .olTileImage {
        /*-webkit-transition: opacity 0.2s linear;*/
        -moz-transition: opacity 0.2s linear;
        -o-transition: opacity 0.2s linear;
        /*transition: opacity 0.2s linear;*/
    }

    /* Turn on GPU support where available */
    .olTileImage {
        /*-webkit-transform: translateZ(0);*/
        -moz-transform: translateZ(0);
        -o-transform: translateZ(0);
        -ms-transform: translateZ(0);
        /*transform: translateZ(0);*/
        /*-webkit-backface-visibility: hidden;*/
        -moz-backface-visibility: hidden;
        -ms-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-perspective: 1000;
        -moz-perspective: 1000;
        -ms-perspective: 1000;
        perspective: 1000;
    }

enter image description here

enter image description here

  • Have had a similar problem recently. I got around it by reinstalling Chrome but I have no idea whether this will fix your problem. – James S Jan 15 '14 at 14:09
  • I have tried re installing it , and problem still exist. You can try it on your PC also : tinyurl.com/p824qnk click the check-boxes on the right till all layers open , suddenly it will happen – Alophind Jan 15 '14 at 18:02
  • Can confirm it happens here too. Very strange. Sorry I cant be of more assistance. – James S Jan 16 '14 at 10:04
  • @JamesS - Can you confirm that in other browsers it doesn't happen ? I have no idea why only chrome. – Alophind Jan 17 '14 at 11:31
  • Yep works fine on IE9 and Firefox 26.0. – James S Jan 17 '14 at 14:20
0

It seems there are old and constant stability problems when running ExtJS applications based, on Chrome:

These problems have been reported to Sencha and Google:

In time, there were new Chrome and ExtJS versions, which brought some improvements:

Unfortunately, again, some users have reported errors:

In this situation, I think you need to test the latest Chrome with different ExtJS versions (like 4.2.1, 4.2.2 or newer revisions) and hope your application isn't affected by the latest incompatibility.

  • I'm using latest GPL licensed Ext 4.2.1 Can't try newer ExtJS because its not GPL yet. – Alophind Jan 15 '14 at 10:38
0

I had a very similar issue and after hours of messing around with it I found that adding padding:'10 0 10 0' to your center region of your viewport will fix the issue.

  • Do you mean adding padding to the mapPanel ? tried mapPanel = Ext.create('GIS.view.Map', {padding:"10px 0px 10px 0px",map: map, tbar: toolbar, bbar: bToolBar, title: appTitle }); and it didn't solve the problem – Alophind Feb 22 '14 at 17:06
  • sencha.com/forum/… The last post there better describes what i had to do. – user27226 Feb 25 '14 at 18:47
  • darn , this didn't solve my problem... but maybe i didn't add it correctly :-/ – Alophind Feb 27 '14 at 1:18
0

As updated in the original post , this is how I solved it eventually.

In OpenLayers css commented out :

/**
 * Animations
 */

      .olLayerGrid .olTileImage {
        /*-webkit-transition: opacity 0.2s linear;*/
        -moz-transition: opacity 0.2s linear;
        -o-transition: opacity 0.2s linear;
        /*transition: opacity 0.2s linear;*/
    }

    /* Turn on GPU support where available */
    .olTileImage {
        /*-webkit-transform: translateZ(0);*/
        -moz-transform: translateZ(0);
        -o-transform: translateZ(0);
        -ms-transform: translateZ(0);
        /*transform: translateZ(0);*/
        /*-webkit-backface-visibility: hidden;*/
        -moz-backface-visibility: hidden;
        -ms-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-perspective: 1000;
        -moz-perspective: 1000;
        -ms-perspective: 1000;
        perspective: 1000;
    }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.