1

Has anybody had any luck getting the tools in the QGIS2 Toolbox to run? So far I have tried SAGA and TauDEM but both throw up errors. I eventually got TauDEM to produce something from the D8 tool by feeding it empty rasters to fill but the results were complete nonsense. Outputting to temporary files did not help at all. It's probably yet another path issue, GIS on OSX seems to be one long series of path issues.

  • And have you installed/compiled TauDEM and SAGA on OSX? – Curlew Jan 13 '14 at 20:32
  • 2
    If you use the the QGIS version of KyngChaos, no need to compile, they are integrated in the package. I have no problem to run the tools (with a few exceptions) – gene Jan 13 '14 at 20:54
  • I am using the KyngChaos installation and nothing in the Processing-Toolbox works. Even GDAL fails, which is odd as it works when run from the Raster menu (and in the command line). This really does seem like yet another path issue. – mercergeoinfo Jan 14 '14 at 8:29
  • Will check the individual installs of SAGA and TauDEM but the GDAL is definitely ok. – mercergeoinfo Jan 14 '14 at 8:32
  • Well SAGA wasn't working. Trying to reinstall using sourceforge.net/apps/trac/saga-gis/wiki/… but make fails for saga as it claims not to be able to find GDAL !!!! – mercergeoinfo Jan 14 '14 at 10:52
2

I just updated the macports Qgis 2.0.1 so that it works with macports Saga port. It's a matter of adding some info in the Info.plist for Qgis to figure out the right path to the other utilities. Grass is still lurching, but I hope to make it work in a matter of a few days.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.