3

When generating pie charts in ArcGIS, it appears that the legend entries generated for the different slices are named based on field name, rather than the field alias.

I've done some research, and found a few historical examples where the user could at least change the labels in the table of contents (example), although it would revert as soon as the layer's properties were changed. In 10.1, it seems that even this ability has been lost.

Is there any way to change the labels for pie charts in the legend, or to force the legend to use the field alias?

6

It took me a while to figure this exact problem out the other day, but yes it is possible to use the Alias in 10.1.

First of all you need to change the Alias name in the Fields tab of your layer. In the example below I have removed the underscore. At this stage make sure you hit apply to save the changes.

Change field Alias

Then if you switch to the Symbology tab and set up your Pie Chart it should have your list of layers in the field selection box. Now at this stage you should be able to see you Alias names rather than the Field name.

If you can't I found that adding and removing them from the chart should do the trick - There doesn't appear to be a 'on / off' switch for using the Alias you just need to play around with it.

Setting layers using Alias

I haven't spent ages playing around with the properties, but I'm yet to have any issues with the labels reverting to the Field Name using this method.

  • What a strange little bug. Works perfectly for me too, no issues thus far. – hfisch Jan 15 '14 at 16:58
0

I did the steps above, but at first it didn't work.

Here's my solution if it doesn't work at first:

  • Close all open dialog boxes.
  • Go back into Properties and changed the symbol to something other than pie.
  • Then, I changed it back to pie, and the steps above worked perfect.
  • The solution of Andy was awesome, of course i had to change the alias, but closing and changing the symbology finally appears the name (aliases) that i wanted – user110377 Dec 3 '17 at 3:32
  • Welcome to GIS SE! As a new user be sure to take the Tour. Here you are trying to make a comment in the area reserved for direct answers to the original question. Such posts are often just deleted but in this instance I will convert it to a comment on Andy's answer.. – PolyGeo Dec 3 '17 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.