1

I'm having trouble setting up TauDEM to work in the processing tools of QGIS 2.0.1.

I download TauDEM from here and select "TauDEM 5.2 Command Line Executables for 32 bit Windows PC". I extract them to a directory called "C:\work\taudem".

I then go into QGIS processing menu > "Options and configuration" under TauDEM I set the "TauDEM command line tools folder" to "C:\work\taudem".

When I execute a TauDEM tool I keep getting errors saying:

Oooops! The following output layers could not be open.

3

I recommend reading the installation instruction for version 5.2 and installed the Microsoft HPC Pack 2012 MS-MPI library i.e. http://hydrology.usu.edu/taudem/taudem5/downloads.html, point 8.

If you don't need the multi file functionality version 5.1.1 might be easier to handle and works for me in QGIS 2.0.1.

Your description sounds a bit like the algorithm is working, but not producing a correct file.

1

I was getting the same error, among others. After many hours of trial and error and searching for answers, I found that the TauDEM 5.1.2 Command Line Executables for 64 bit Windows PC works for me in QGIS 2.6.0 on my 64 bit Win 8.1 machine. I couldn’t get 5.0.6 or 5.2 to work as advised in various other posts I’ve read.

1

I'm using QGis version 2.6 on a windows PC and TauDEM is a plugin that you can enable by going to Processing --> Options --> Providers --> TauDEM --> Activate.

0

I have not tried it yet, but a colleague of mine got it working in QGIS partly using the installation instruction for ArcGIS here http://hydrology.usu.edu/taudem/taudem5/downloads.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.