2

Has anyone out there any experience with a plugin to QGIS called Layers menu from project? This plugin gives you fast access to layers that you specify in a Qgis-project file.

It won't work on my computer. It appears to be set up correctly, but won't open any shapefiles when I click on them.

Does this make any sense?

1
  • 1
    Welcome to gis.SE. When you say it won't open, what happens instead? Which specific version of QGIS and which specific version of the plugin are you using? What environment are you using? How did you install the plugin? All of these useful bits of information can be added to the question if you click "edit" above.
    – BradHards
    Jan 15, 2014 at 9:33

2 Answers 2

3

The plugin works for me. It is required that the sources in the original projects are saved with absolute paths, which is not default.

You can change that under File -> Project Settings, General tab. Then save the project file, and the plugin should know where to find the shapefiles.

WMS and tile services like Openlayers plugin should work anyway.

4
  • YEEEEEESSSS!!! Thank you so much! I have been trying to figure this out for weeks now :) Jan 16, 2014 at 10:26
  • Please mark the answer as accepted; and never remove the project files you added to the plugins list externally via Windows Explorer. I had to remove the plugin to avoid annoying error mesages on startup.
    – AndreJ
    Jan 16, 2014 at 10:41
  • I added a ticket for your problem: hub.qgis.org/issues/9354
    – AndreJ
    Jan 16, 2014 at 11:10
  • Both bugs are solved by now.
    – AndreJ
    Jun 14, 2014 at 14:18
2

Your comments are sound and have been integrated into version 0.7 (qgis 2.2), thank you !

The plugin also works with embedded layers.

Xavier

1
  • Thanks for the feedback. But please note that on this site there is a difference between "answers" and "comments". I think your message should rather be a comment on the question, or on my answer.
    – AndreJ
    Jun 12, 2014 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.