1

I am trying to upgrade Opengeo Suite from 2.0 to 4.0, specifically for the upgrade of PostGis 2.0 to 2.1, I followed the instructions outlined on this page: http://suite.opengeo.org/opengeo-docs/installation/ubuntu/upgrade.html But had no success.

I realized I hadn't fully installed opengeo-client or postgis 2.1, so I used apt-get install and received this:

The following packages have unmet dependencies:
opengeo-client : Depends: postgis-2.1 (>= 2.1.0) but it is not installed
postgresql-9.3-postgis-2.1 : Depends: postgis-2.1 but it is not installed
E: Unmet dependencies. Try using -f.

So I used -f and received..

The following extra packages will be installed:
  postgis-2.1
The following NEW packages will be installed:
  postgis-2.1
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
28 not fully installed or removed.
Need to get 0 B/701 kB of archives.
After this operation, 1,839 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
dpkg: warning: files list file for package 'postgresql-9.2-postgis2' missing; assuming                     package has no files currently installed
(Reading database ... 384786 files and directories currently installed.)
Unpacking postgis-2.1 (from .../postgis-2.1_2.1.0-1+opengeo_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/postgis-2.1_2.1.0-1+opengeo_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/shp2pgsql-gui', which is also in package postgis 1.5.3-2ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/postgis-2.1_2.1.0-1+opengeo_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I was recommended to go back and forth with apt-get upgrade and apt-get -f install to isolate the issue. But I am assuming that Postgis 1.5 is still in use, but I cannot find where to remove it. (If it is possible to do a complete wipe of the Opengeo suite then I can also do that if it would be simpler, all of my data is backed up)

I am not experienced in Linux. Most of my work is on the GIS/Web side.

My Ubuntu release is: Ubuntu 13.04 Raring

3

Had the same issue on 12.04 while upgrading from 3.0 to 4.0.2.

The following command seems to solve it in my case:

sudo dpkg --purge opengeo-postgis-shapeloader

And then run the opengeo upgrade command again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.