2

I'm trying to use the ArcGIS 10 animation system to produce a time series of points by year. There are only 65 years in the dataset, and I want to make it so there is only one frame per year. I have tried setting it to play a certain number of frames and frame duration, or by total duration, but when it exports, it alters the frame rate and adds a number of duplicate frames when I export to AVI or as sequential images.

Is there a way to export only a single frame for each year? The interval and units are set to 1 year.

  • Did you 'calculate' the frame for your animation? - you can manually change this: resources.arcgis.com/en/help/main/10.1/index.html#/… – Mapperz Jan 15 '14 at 20:22
  • I am just using the basic animation extension, not tracking analyst. I had tried setting the frames and frame duration manually, but I think this just tells the exporter how long the animation should be, and then it adjusts the frame rate regardless. – TDavis Jan 15 '14 at 20:33
  • In your point dataset are there 65 rows, one for each year? – Hornbydd Jan 15 '14 at 20:48
  • there are a few thousand rows, the time is defined by a year attribute for each record – TDavis Jan 15 '14 at 21:10
1

I ended up using the animation interface in tracking analyst to set the frame count, as suggested by Mapperz in the comments, which provides more options for controlling the output than the animation tool controls or the time slider. The output was in .bmp format, rather than the .gif format of the animation toolbar sequential image option. Just thought I should post it here so the question doesn't sit here unanswered, but all credit goes to Mapperz.

  • I think you should accept you own answer, if you/Mapperz solved it (+1). Tks. – Andre Silva Feb 28 '16 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.