0

I have GeoServer installed on Windows XP as part of the OpenGeo bundle. It's working well and I have just started creating my own app using it.

I have created an html file in \WebApps\apps and can view it via localhost:8080. My problem is that once I have viewed the file in a browser it becomes locked and I can't save over it.

Has anyone else had this problem? Is there a fix?

1

I have experienced the same with Notepad++. There is no fix that I'm aware of, but a workaround - use plain Notepad, which will still let you write the file. Other text editors may also work, but I haven't tried.

1

Not a fix for GeoServer, but you can unlock files that are locked by other processes by using Unlocker. Crucial utility to have installed on your system.

  • I tried it - it didn't work. Useful piece of software though. – Mr_Chimp Apr 8 '11 at 14:15
0

This caught me out for a while and that codehaus link no longer works so for reference (based on the OpenGeo suite install but applicable with any Jetty geoserver setup probably)...

Main one to enable editing and saving html files in root is D:\Apps\OpenGeo\jetty\etc\webdefault.xml set useFileMappedBuffer to false (was true)

Cheers Andy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.