1

I have developed a web map application by using Geoserver 2.4.0 and tomcat 7 in Windows XP.

I have tried to configure the GeoWebCache for WMS layers to speed up the service but unfortunately it didn't work for me. I did something wrong in configuration steps. Kindly Help me to achieve this. I have attached some screenshots for reference.

enter image description here

I have created New Gridset for EPSG:404000

enter image description here

I have tested with XXX.XXX.X.XX:8080/geoserver/gwc/demo Link:

enter image description here

My layer setting is:

enter image description here

And My Geoserver Log is:

at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:953) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408) at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1023) at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:589) at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) 2014-01-18 10:30:31,901 ERROR [geowebcache.GeoWebCacheDispatcher] - Problem communicating with GeoServer http://xxx.xxx.x.xx:8080/geoserver/gwc/service/wms 2014-01-18 10:30:31,901 INFO [geoserver.wms] - Request: getServiceInfo 2014-01-18 10:30:31,901 ERROR [geoserver.ows] - org.geoserver.platform.ServiceException: No such style: ODC_Raster at org.geoserver.wms.map.GetMapKvpRequestReader.parseStyles(GetMapKvpRequestReader.java:1386)

My Default Raster Style:

enter image description here

My Custome Raster Style:

enter image description here

Thanks in advance

2

As you can see in the browser there are no png tiles in the GeoWebCache.

You must go to Tile Caching > Tile Layers > Add a new cached layer to add your layer in GWC.

Then press seed/truncate and you'll see a dialog where you can choose the zoom levels and the tile format (jpg/png).

Don't forget to enable the Disk Quota, if you want to see the current disk space used by the cached layer tiles.

  • Yes already Create a cached layer for this layer and Enable tile caching for this layer options are enabled. – venkat Jan 17 '14 at 5:40
  • Now I have added my layer setting screenshot above. Is there anything I did wrongly? – venkat Jan 17 '14 at 5:52
  • Also, check your GeoServer log to see what happens. – Sorin Călinică Jan 17 '14 at 13:10
  • Thanks for your response. I have updated the Geoserver log above. Its says Problem communicating with GeoServer like. I am very new to geoserver.Plz help me to fix this. – venkat Jan 18 '14 at 5:08
  • You need to enter to Data>Layers and click your layer name. Then choose the Publishing tab and scroll to WNS Settings section. Choose raster for the Default Style and finally Save. Now everything must be ok. – Sorin Călinică Jan 18 '14 at 6:22
0

I think you have issues with your style. Can you preview the layer in GeoServer?

Why not try creating the layer again, start from the beginning, ensure that it is visible in GeoServer first, perhaps with a default style, then try GWC. Usually when you have those tiles that look like missing images, it means that the style is busted or you have a bad geometry in a vector (clearly not that here!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.