EDIT 10/20/2011:

The problem I was having below was caused by trying to install Python(x,y) after ArcGIS 10. I got a new machine yesterday and instructed IT to install Python(x,y) (has correct numpy version for Arc). I had them run a non-scripted installation of ArcGIS 10 so we could make sure the installer didn't try to give us a second version of Python. I now have a single Python directory and ArcPy works (so far); as of right now I'm considering this issue resolved.

I have what would seem to be an issue with a clear and easy answer, but so far I haven't been able to find a suitable one.

Here is the situation:

I need to have both ArcGIS 10 and Python(x,y) installed on a server that is accessed by multiple users in order to accommodate everybody's needs. Because both of these pieces of software install their own version of Python 2.6, the libraries installed by one cannot be accessed by the other. In other words, if we install ArcGIS before Python(x,y) we can use all of the goodies like MatPlotLib, numPy, etc., but the arcPy module is unavailable and vice versa.

To solve this problem I tried adding the path to the various libraries to the python path of the "active" version of Python to no effect, ala this thread: Problems setting up eclipse (with PyDev) for ArcGIS 10.

We could possibly resort to installing ArcGIS 10 and then try to manually install all of the libraries that are included with Python(x,y), but this would not be an ideal fix. Alternatively we could install ArcGIS 9.3.x since that comes with Python 2.5, but I would prefer to have all of the functionality that is available with the new arcPy module. If someone out there has already encountered this and has any other suggestions I'm all ears!

We are working in the Windows Server 2008 R2 environment.

2 Answers 2


So you're using the version of Python(x,y) with Python 2.5 and ArcGIS 10, which uses Python 2.6? If this is the case, it will not work regardless as Python extensions written in C are not binary compatible across versions.

  • No, we're using Python(x,y) with Python 2.6; what we're ending up with is 2 separate installs of Python 2.6. One from Arc 10 and the other from Python(x,y). Is there any way to prevent ArcGIS from installing Python if there is an available version of Python 2.6 already there? Apr 8, 2011 at 19:37
  • ArcGIS expects Python 2.6 to be installed in c:\Python26\ArcGIS10.0 etc etc I suspect any deviation from this path structure will cause issues with ArcGIS
    – user681
    Apr 8, 2011 at 19:46
  • @Jason Scheirer: I guess that means that the second of my two alternative, less desirable workarounds is not feasible. It makes sense as I would have to call up arcgisscripting from Python 2.5 and then turn around and try to use Python 2.6 to access the other libraries. Do you have any ideas on a harmonious coupling of these two pieces of software? Apr 8, 2011 at 20:17
  • 3
    10.0 should not overwrite any existing installation of Python, perhaps this is a bug in the installer? For the canonical location of the 2.6 interpreter on any machine, look in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Python\PythonCore\2.6 and make sure it's pointing to the right one. And you can always grab the Desktop10.pth file ArcGIS lays down in its own site-packages directory and copy it into the (x,y) install's site-packages directory. Apr 8, 2011 at 22:28
  • 10.0 didn't overwrite anything, it was just the fact that there were two installations of Python 2.6 that was causing the problem. We (I don't have admin privileges) tried copying path files and changing some registry keys, but the one you mentioned above sounds like a different one. I'll post an update here as soon as I can get IT to work on this for me. Thanks for the help. Apr 11, 2011 at 13:52

Going through the same issue at the moment. I'm pretty sure the issue is in the version of NumPy - ArcGIS requires NumPy 1.3.0, but Python (x,y) installs Numpy 1.5.0. I'm going to have a play this afternoon to try and get around it - I'm thinking do a custom install of Python (x,y) without installing numpy, installing the 1.3.0 numpy binaries, and then installing ArcGIS 10.

No dice I'm afriad. Still pretty sure that it's the NumPy version, but without installing that you might as well not install Python(x,y) as so many other packags rely on it.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.