2

I have sample points within a single polygon feature class that I would like to interpolate, likely using kriging. The problem is the sample points and polygon boundaries are many miles apart and therefore the kriging interpolates across these many miles. Is there anyway I could force the kriging to only interpolate within the polygons and not across what looks to be extents of the polygons. Another way of saying this is let's assume I have sample data points in Missouri and Ohio and I want to compare across these two states so any chance I could merge the 2 states in single feature class and interpolate them together? It just creates a big rectangle to the extents when I try kriging this data.

2
  • I am having problems with this issue. I have created a polygon shapefile that basically defines the geoprgaphic boundary of a set of points containing air concentration data, which i would like to interpolate (again using a Kriging model). I have set the mask to this polygon, but my output continues to be a large rectangle defined by the most northern, easter, southern and western points where the data was measured. There are large swathes of interpolated data (in the SW and NW corners of this rectangle especially) that are more or less non-sensical outputs as there are no points close to inte
    – David M
    Commented Nov 2, 2016 at 16:04
  • Hi David. Welcome to GIS stackexchange. You will not get help in this way, best thing is delete this and post it as a new question.
    – Matt
    Commented Nov 2, 2016 at 16:23

2 Answers 2

5

If you want to limit kriging to only interpolate within the polygons, you could adjust your Environment Settings. You can do this by selecting Geoprocessing - Environment Settings. Within there you should select Raster Analysis. This is where you can set the Mask for your workspace. Raster Analysis performed in your workspace will only be performed within the boundary of your set Mask. So, in your case, you would want to select that polygon layer as your Mask.

2
  • Thanks hurlski, that did the trick. I do have what sort of strange thing going on where it's leaving out some of the far edges of the polygon I'm using in the mask. Like maybe they don't match the 4 outer extents of the polygen area or something. Any ideas on what my be going on there if I'm explaining that well enought?
    – wilbev
    Commented Jan 19, 2014 at 23:20
  • 1
    I think you should look into your Environment settings, specifically the Processing Extent. I don't know exactly what is going on with your dataset, but it sounds like it could be a misalignment issue. You can correct this by adding a Snap Raster under the Processing Extent section of Environment Settings. You might also want to take a look at the Cell Size settings in the Raster Analysis section. Good Luck
    – hurlski
    Commented Jan 20, 2014 at 1:26
-1

In order to preserve the exact area of the polygon, you must do the following three steps: First, export your polygon shapefile into a layer file. Then, in the Kriging window, select "Environments...", go to "processing extent, and change the "extent" from default to "the same as the "layer" file of your polygon.". third step, again in "Environments," "Raster analysis," choose your polygon of interest in the Mask section. and you are good to go.

3
  • A layer file isn't an "export" format, and the accepted answer already recommends this procedure.
    – Vince
    Commented May 31 at 11:44
  • Yes, following the accepted answer although, it limits the edges of the output raster to the outermost points (of the input point shapefile) and does not include the entire defined polygon area.
    – ami darban
    Commented May 31 at 12:41
  • The accepted answer already specifies to use the polygon layer for the mask extent.
    – Vince
    Commented May 31 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.