7

I have downloaded and installed QGIS. I would like to georeference an image using the core georeference plugin. When loading it no toolbar appears and the 'update', 'reinstall' etc boxes in plugin menu are also greyed out.

Any clues?

  • I am having the same problem. I select the menu item from the Raster menu and the Qgis window just blinks, loses focus and nothing happens. Re-installing Qgis 2.4.0-Chugiak does not work. Restarting the computer does not work. Any suggestions? – user37560 Sep 29 '14 at 6:18
  • This is crazy. The problem was the window was displaying on a external monitor that was not hooked up to my computer. This is a glitch that should be fixed. Any extension that brings up a separate window should somehow check which monitors are actually hooked up and should not display itself on a monitor that does not exist. By the way, I am not talking about not turned on, or anything else. I am talking about nothing plugged into my computer at all. All of the relevant 'Extend your desktop' ect. settings were not even available because there was no additional monitors hooked up. – user37560 Sep 29 '14 at 6:49
  • If the OS knows what monitors exist, so should Qgis. – user37560 Sep 29 '14 at 6:56
  • This one solved it for me: gis.stackexchange.com/questions/274503/… – danwild Nov 21 '18 at 5:50
13

I had the same problem. This should solve the bug (QGIS 2.6 under Windows):

  • close QGIS
  • using regedit.exe, search for "Plugin-GeoReferencer". This should point to a folder under \HKEY_CURRENT_USER\Software\QGIS\QGIS2\Plugins
  • (optional: export a .reg version of the fodler for back-up)
  • delete the folder "Plugin-Georeferencer"
  • restart QGIS. Georeferencer window should now open
  • Great solution that works! – CARTOS Jan 30 '17 at 21:23
  • Works great. in my case the folder was \HKEY_CURRENT_USER\Software\QGIS\QGIS2\Plugin-Georeferencer – JimS-W Mar 5 '18 at 14:11
5

This is still a problem in QGIS ESSEN 2.14.0 I normally use two screens when I georeference and it seem that QGIS remember this somehow. To find my georeference window I have to change my setting to "extend this displays" despite not having a second screen hooked up. Then go fishing for the window to drag it into you working screen.

4

Did you check in the Raster menu that is where it lives.

You can't update or reinstall it because it's a core C++ plugin.

3

I had this problem as well in 2.18.3.

My solution was to go to regedit.exe, search for Plugin-Georeferencer. In that library you will find "Pos". The georeferencers position on the screen.

My position was: @Point(-1713 266). By changing this to a place within my screen resolution (I simply deleted the minus) the window appeared on screen at next startup and I could drag it in place.

Hope this helps.

0

What worked for me is that I changed the resolution of my screen to anything lower and then back to my default resolution. The Georeferencer window was back immediately!

-1

Alternative to BLet's answer you don't have to delete the "Plugin-Georeferencer" folder in regedit.

In the "Plugin-Georeferencer\Config" folder just change the 'ShowDocked' attribute to 'true' and the plugin is opened as docked in QGis.

From there just drag the window to wherever you want.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.