1

I am trying to use a bluetooth GPS with a couple of base layers in QGIS. The GPS/bluetooth connection seems to be working great...I can connect and disconnect without issue. I've set my project CRS to WGS84, and I've enabled OTF CRS transformation. I've confirmed the CRS for my base layers is set properly. However, I can't zoom to my base layers to know if my GPS point is lining up where I think it should be with the base layers. Whenever I click 'Zoom to Layer Extent', nothing happens. Any thoughts on what I might be doing wrong?

I am using QGIS ver. 2.0.1 on a Windows 8 32-bit tablet.

  • On which layer are you trying Zoom to Extent? The GPS layer may not have an extent until the data is saved to disk. – AndreJ Jan 18 '14 at 5:36
  • Definitely one of the base layers. As far as I can tell, the GPS is not behaving as a layer. But the extent seems correct for the GPS as it is in decimal degrees. Please forgive me, I am new to QGIS. I am looking for a low cost GPS/mobile GIS solution that can be managed on a tablet. The QGIS software seems to be vert capable, so I'm hoping I've just overlooked a setting somewhere? Thanks... – MonkeyEdit2000 Jan 18 '14 at 23:41
  • What do you use as Base layer? OpenLayers plugin will have the whole world as extent. Try a country shapefile from gadm which will give you a defined extent of your country. – AndreJ Jan 19 '14 at 6:36
  • I was attempting to use base layers (shapefiles) from the state level. They are in UTM10, NAD83. If I unproject the base layers to WGS84 in ArcGIS, and load them into QGIS, the live GPS overlays as expected with the base layers. I would love to make this work without having to reproject first. It seems this may be a projection issue, but I need to determine if it is an issue with my base layers, if there is a bug in the OTF transformation model in QGIS, or perhaps the GIS plugin only works with layers in WGS84. Thanks very much for your suggestion to try a base layer in WGS84! – MonkeyEdit2000 Jan 22 '14 at 18:33
  • There is nothing wrong with OTF in QGIS, it works for me. Please check carefully if all layers have the right CRS assigned using Rightclick -> Set CRS for layer. In Settings -> Options -> CRS` tab choose "Ask for CRS of new layers" to make sure QGIS does not silently assign a wrong CRS. – AndreJ Jan 22 '14 at 18:44
1

Based on troubleshooting tips from Andre, we determined that my issue really had nothing to do with QGIS and CRS OTF not working properly. I was not using the correct transformation parameter for my base layers; this was my problem. Once I figured this out, my live GPS and base layers aligned perfectly. Props to Andre for helping me through this! - Mark

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.