2

I want to work with a shapefile that is in a Coordinate System that I can't locate in QGIS for Mac. When I load this shapefile data, it shows up fine, on-the-fly has generated the CRS data most likely from the .prj file that has the info in it. However, if I add a coastline from WGS-84 coordinates, or any other data from another coordinate, my data ends up in Africa or even farther than that! So I try to set a coordinate system for it so QGIS will have a reference point. I type in the filter 102631 because that is the number for the Projection data, but that projection isn't listed.

What do I need to do? Can I manually alter something so QGIS has a reference point for this projection data?

The shapefile was created in a NAD-83 Alaska Coordinate System (NAD 1983 StatePlane Alaska 1 FIPS 5001 Feet ESRI 102631 http://spatialreference.org/ref/esri/102631/).

On QGIS for the Mac this coordinate reference system is not listed. How can I correct this on the Mac? Is there a way to download more Projections?

  • Thank you for your help, Chris and Andre. Even after entering the Proj4 string my data was off. I was able to use a PC and fix the data on there where the ESRI 102631 code is found. Here is the data [link]drive.google.com/… – jfact0ry Jan 21 '14 at 20:33
2

According to this ticket:

http://trac.osgeo.org/gdal/ticket/4910

GDAL (and using that also QGIS) has some problems with omerc projections.

This might be the reason why you did not get your data in the right place with the information in the .prj file. If possible, try to get your data in another projection like UTM or WGS84, or ask someone who uses ARCGIS to reproject it for you.

The Windows version QGIS 2.0.1 Dufour lists the ESRI projection under EPSG:102631, but I'm not sure if it is handled correctly.


EDIT

Loading your data, and assigning EPSG:102631 to it, places the buildings in the right place:

enter image description here

proj string of the EPSG code is:

+proj=omerc +lat_0=57 +lonc=-133.6666666666667 +alpha=-36.86989764583333 +k=0.9999 +x_0=4999999.999999999 +y_0=-4999999.999999999 +no_uoff +datum=NAD83 +units=us-ft +no_defs

Adding the shapefile without correction, the following user defined CRS is created:

+proj=omerc +lat_0=57 +lonc=-133.6666666666667 +alpha=-36.86989764583333 +k=0.9999 +x_0=4999999.999999998 +y_0=-4999999.999999998 +gamma=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +units=us-ft +no_defs

.prj file content is

PROJCS["NAD_1983_StatePlane_Alaska_1_FIPS_5001_Feet",GEOGCS["GCS_North_American_1983",DATUM["D_North_American_1983",SPHEROID["GRS_1980",6378137.0,298.257222101]],PRIMEM["Greenwich",0.0],UNIT["Degree",0.0174532925199433]],PROJECTION["Hotine_Oblique_Mercator_Azimuth_Natural_Origin"],PARAMETER["False_Easting",16404166.66666666],PARAMETER["False_Northing",-16404166.66666666],PARAMETER["Scale_Factor",0.9999],PARAMETER["Azimuth",-36.86989764583333],PARAMETER["Longitude_Of_Center",-133.6666666666667],PARAMETER["Latitude_Of_Center",57.0],UNIT["Foot_US",0.3048006096012192]]

parameters are mostly the same, only gamma=0 is added, and +no_uoff is skipped. The result is in Africa.

So same as the other bug cases: EPSG code is correct, while user defined CRS gets wrong. And you are out of luck if you don't have those ESRI codes in QGIS.

2

Using a Proj4 string you can create a custom projection in QGIS. From the spatial reference link you provided the Proj4 string is as follows:

+proj=omerc +lat_0=57 +lonc=-133.6666666666667 +alpha=-36.86989764583333 +k=0.9999 +x_0=4999999.999999999 +y_0=-4999999.999999999 +ellps=GRS80 +datum=NAD83 +to_meter=0.3048006096012192 +no_defs 

In QGIS 2.0 (on a Mac OS X 10.8.5 which is what I am running) you would go to menu > Settings > Custom CRS. Click on "Add New CRS" then give it a name and copy and paste the Proj4 string into parameters. Then click "Okay" to close the dialouge box.

You should now be able to reference the projection in Project Properties under User Defined Coordinate Systems. You'll have to scroll to the bottom of the selectable coordinate systems in Coordinate Systems of the World.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.