2

I am using QGIS 2.0.1-Dufouron on Windows 7. When I try to load nviz via GRASS, I get the message "Module nviz not found". Weirdly enough, I can load it via the toolbox and be able to 'run' it (it reaches 100%). But afterwards, nothing happens.

Problem: I merely want to rotate and play around with the view points of layers. This is all for aesthetic purposes, don't want to do anything technical (not yet anyway).

I have read posts on people suggesting to install the plugin SEXTANTE which may solve the issue, however it doesn't show up on my list of plugins (maybe I don't have the correct URL?). I am considering trying ArcMap if I have to but would rather do it in QGIS.

Any suggestions please?

  • SEXTANTE in QGIS is now called processing and is integrated into QGIS since version 2.0. Just open the toolbox from the menu (Procession Toolbox) – Curlew Jan 21 '14 at 12:08
  • @Curlew Thank you for replying. In that case, I do have SEXTANTE installed and it seems that I can run nviz from there but I no results are shown. – Joseph Jan 21 '14 at 12:26
  • On windows you need to have tcl and tk installed as well as grass and the nviz extension. Did you do all this stuff? – Curlew Jan 21 '14 at 17:07
  • I have compiled/installed tcl/tk and GRASS. When I run nviz via the toobox in QGIS now, it processes the data which wasn't shown before but still no results when it reaches 100%. – Joseph Jan 22 '14 at 13:59
  • Even i also tried to open and work with 3D functionality in nviz but there are no any result shown. previously i was using 2.2 but currently i am using QGIS 2.4 but isuue is history repeats again in 2.4 while running nviz from sextante. does anyone have the solution of this? – suyogpatwardhan Jul 22 '14 at 6:19
1

Nevermind...got it working by installing and ONLY installing WinGRASS-6.4.1.

Version 6.4.3 does not load, not for me anyway. Can finally run nviz perfectly instead of wasting time installing Ruby, tlc/tk, Python and various drivers seperately.

1

Installing the standalone installer worked for me (winGRASS 6.4 standalone installer)

http://grass.osgeo.org/grass64/binary/mswindows/native/WinGRASS-6.4.4-1-Setup.exe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.