4

I am trying to join a data table to the attribute table of a shapefile. I have done all the necessary steps to makes sure it works: removed spaces, not use numbers in column headers, remove illegal characters etc. BUT still when I try to join the table, Arcmap is not reading the GEOID field that I am trying to use to join the two tables. I cannot see it listed in the fields to join. What could be the problem?

  • How is the data table you trying to join to stored? What format is it in? – HeyOverThere Jan 22 '14 at 16:06
  • I am using the GEOID field in a TIGER census block group shapefile to GEOID of the block group census data – Dr.Apell Jan 23 '14 at 16:39
3

If the field has a different type in each table (short vs double; long vs string, etc), non-matching fields won't show up in the join dialog, so you have to make a new, type-matching field

  • I think this is the issue. Now the question is how do i modify the field in att table of shapefile to numeric value. or does it always have to be able to match text? – Dr.Apell Jan 23 '14 at 16:42
  • you can't adjust the type of existing fields, you can create a new field of the proper type (options/add field...; enter name, select the appropriate type, and click ok) then right click on the new field and select 'calculate values'. in the field calculator, double click on the original field name, and it should appear in the expression window. click ok, and you should have a new field of the correct value and type to match to the join table. – TDavis Jan 23 '14 at 16:47
  • Ok that worked. I created a new field and changed the GeoID field to "double" then did a calculate field and voila!! worked like a miracle – Dr.Apell Jan 24 '14 at 17:48
2

Whenever I encounter this problem I check to see if there are any previous joins between the tables you are trying to join. Then, making sure they are of compatible field types.

  • And maybe restart Arcmap... – Martin Jan 22 '14 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.