0

I have been desperately trying to install QGIS version 2.0.1 Dufour, but in the middle of the installation I always get an error ("Extract Error writing to file oraociei1.dll"). And automatically installation is aborted ("Setup was not completed succesfully").

I have tried so many times and also tried to download from different websites, not only from qgis.org, but nothing helps. Sooner or later I get the same type of error and that was it...

Any ideas what I could do?

  • Can you try installing with the virus scanner disabled? Maybe that's blocking the file. – SaultDon Jan 23 '14 at 23:13
  • 1
    What OS are you working on? Does the file already exist on your system, but is used by another process? – AndreJ Jan 24 '14 at 6:22
4

oraociei1.dllbelongs to Oracle Instant Client. Therefore you must have an active process (background application) which is used commonly to connect to an Oracle Database. If you'll stop that process then it is possible to have a smooth QGIS installation.

To easy find which process is locking your dll, please open a command line, type the bellow command and press enter:

tasklist /m oraociei1.dll

After a while, possibly, you'll get something similar to this:

enter image description here

It remains to you only to shutdown/kill these applications/processes prior to the QGIS installation.

  • Thank you everyone for ideas! Sorin, you were right, it was used by another process. Thanks a lot for helping me out! – mina Jan 24 '14 at 12:24
  • Hi, I got a similar problem as yours, which I am under Win7-64 bit and trying to install QGIS 2.16, I got the error of 'Extract Error writing to file oraociei11.dll', and I checkedcmd before installing, which there were no process using this dll, how to solve this problem? – Heinz Oct 17 '16 at 4:07
0

It is also worth to check free space on disk C:

oraociei12.dll is a big file, and it may not fit into installer's temporary directory.

0

I got the same error while installing QGIS 3.6.2 and QGIS 3.4.7. I tried a lot of different things, then restarted my computer, and then the installation finished without any issue. Maybe it was just restarting that fixed the issue, but just in case it wasn't here's everything I tried:

  1. I tried installing to a different drive (my computer has 4), but I got the same error message on the second drive.
  2. Found this Stackexchange post, and tried the solution suggested by Sorin Călinică (using the command line to find out what process is locking my dll). But the command line informed me that nothing was using it.
  3. Made sure the drive to which I was installing had enough free space. Both drives had more than enough free space according to the installation wizard (required space: 2.0 GB, available space: more than 40GB).
  4. Repeat the installation multiple times. Each time it seemed to get a little bit further before hanging up on a different file (including but not limited to h5ls.exe, h5stat.exe, h5diff.exe, gdal204.dll, gsdll32.dll, qtcanvas3dd.dll). At first it felt like I was making progress, but after 10+ failed installation attempts I gave up on this method.
  5. Quitting unnecessary background processes from the Task Manager (Skype, several cloud storage programs, Origin, Steam, etc).
  6. Delete temporary files from the drive I was installing to, and from other drives on my computer. Start menu > Settings app > System > Storage > select a drive > Temporary Files > select which types of temporary files to delete. Be sure to read the descriptions of the different file types and be sure not to delete anything that sounds important. I deleted temporary files created by apps, temporary internet files, and delivery optimization files.
  7. Uninstall all other versions of QGIS, and delete the few files that remained in their folders after the uninstallation process. This is a risky move if you already have a functional version of QGIS installed, but I had 3.4.1 which kept crashing so it seemed like a risk worth taking.
  8. Disconnect the computer from the internet.
  9. Restart the computer.

I re-tried the installation after every step above. Steps 4-7 may have helped, or maybe it was just restarting that fixed the problem. Whoops. Should have tried that first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.