4

My specs: ArcInfo 10.1, Oracle 11g

I have a line dataset which is sat in Oracle 11g. I can read/query/symbolise this in ArcDesktop without any problems.

I now want to export a selection into a file geodatabsae, but I keep getting this error:

The name it gives in the error (U1BLine) is the name I am trying to give my exported dataset.

I have tried exporting only the selection and the whole dataset. I get the same error with both.

I have also tried to export it to a shapefile. This works.

I know I could export to shapefile and then move that into a geodatabsae, but I'd like to be able to do it in a single step.

Other datasets from the same Oracle database have exported without a problem.

Both the dataset and the dataframe are set to British National Grid.

Anybody know how to fix this error?

7

This problem has to do with spatial index. When you export the data into a new workspace, be it a file geodatabase or a shapefile, the export process creates a new feature class in the target workspace. The new feature class is then assigned a spatial index according to the default environment variables in your ArcGIS. There are some rules when setting these spatial index grid parameters, some of them have to do with the size of the grid created by the spatial index. You just have to make sure these parameters are properly set according to the following image.

In ArcMap Menu, point to Geoprocessing, and then select Environments. From the Environment Settings window, expand Geodatabase Advanced link. In the Output Spatial Grid 1 type 50, in the Output Spatial Grid 2 type 150 (make sure it is always larger), if you want to use a third spatial grid type in a number larger than 150, or simply 0 if you don't want to use it. Leave the rest of parameters to default settings.

Of course you can always set them all to zero if you don't want to use a spatial grid.

Spatial Grid

Then right click on the layer you want to export and point to Data, then Export.

Export

1

You seem to be encountering tool error 001153 and the advice offered in the ArcGIS Online Help is:

Description

A grid size has been specified that is too small.

Solution

Specify a grid that is at least three times larger than the preceding grid size.

The Output Spatial Grid 1, 2, 3 (Environment setting) help page is worth reading in connection with the above.

0

What worked for me was to export the data in shapefile format. This can then be imported into a geodatabase if required. Note that exporting to shapefile will result in field names being truncated if they exceed 10 characters.

0

Another option is to create an empty feature class in your destination geodatabase with an identical schema to the source table in your Oracle database (Data Management -> Feature Class -> Create Feature Class; use the source table as the Template Feature Class), and then append the records from one to the other.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.