1

What is the correct URL to enter in ArcCatalog WFS parameters when adding a WFS layer from GeoServer into ArcMap?

Here's a link to our GetCapabilities document:

https://weaveprod.ucdp.utah.edu/geoserver/ows?service=WFS&version=1.0.0&request=GetCapabilities

I am using ArcMap 10.1 and experiencing the same problem described here. When I try to add WFS layers from GeoServer, "Feature Types" is blank. That post says it is a bug with 10.1. However, I added WFS from GeoServer not long ago, so I'm skeptical that the answer is to applicable to 10.2. The only thing that changed was our GeoServer location.

I was able to bring in WFS layers from:

http://www2.dmsolutions.ca/cgi-bin/mswfs_gmap?version=1.0.0&request=GetCapabilities&service=WFS.

Although that is not GeoServer, I previously had GeoServer WFS working fine.

Here's an image of one URL I tried (which was:

https://weaveprod.ucdp.utah.edu/geoserver/sf/ows?service=WFS&version=1.0.0&request=GetFeature?

No matter how I change it, no layers are coming up in feature types. There shouldn't be any problem with my WFS layers because I can preview them as WFS through GeoServer.

Adding WFS in ArcMap

  • I just tested this using ArcGIS 10.2 for Desktop with your service URL and I see the same issue. – PolyGeo Jan 27 '14 at 21:01
  • I think when I did this I had to specify the layer in the URL and could only add one at a time – tomfumb Jan 27 '14 at 21:12
  • Interesting that it doesn't work at 10.2 either. Thank you very much for checking. Also, I tried using a url to only one layer, but have the same problem. – nyoung Feb 7 '14 at 19:18
4

I was able to add the data.

I am using ArcGIS 10.3.1, using the Data Interopability Connection, and I was able to bring in the bugsite feature class.

URL: https://weaveprod.ucdp.utah.edu/geoserver/ows

Parameters: enter image description here

Results: enter image description here

2

When defining URL try to delete everything after a questionmark i.e. only:

https://weaveprod.ucdp.utah.edu/geoserver/ows?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.