1

I've created a grouped layer made from 4 MrSID rasters. I have a Openlayers map with basic Google layer. When I preview the grouped layer in geoserver , I see that tiles are being created in the GWC folder (tried both EPSG:4326 and EPSG:900919).

When I view the layer in my openlayers application (on same localhost machine) , no cached tiles are being created (I've cleared the browser cache to make sure the tiles are being generated from geoserver).

In my Openlayers I'm using GeoExt2 ... but still its regular WMS call.

Any idea why no tiles are being generated ?!

  • Tiles won't be created if you are hitting the WMS service, even if you have GWC installed and configured. To create the tiles, either seed the cache, or hit the GWC end point. And remember, if you want to consume the tiles, you need to use the GWC URL, not the WMS url. – Devdatta Tengshe Jan 28 '14 at 14:09
  • If I seed the cache , calling the WMS will use the cached tiles or I must call GWC ? – Alophind Jan 28 '14 at 14:55
  • You will have to call the GWC – Devdatta Tengshe Jan 28 '14 at 14:56
3

The Geoserver Documentation mentions:

GeoWebCache is a tiling server. It runs as a proxy between a map client and map server, caching (storing) tiles as they are requested, eliminating redundant request processing and thus saving large amounts of processing time. GeoWebCache is integrated with GeoServer, though it is also available as a standalone product for use with other map servers.

GWC can act as a Wrapper to the WMS and you can use it in your app by using an url like: http://example.com/geoserver/gwc/service/wms instead of http://example.com/geoserver/wms

If you want to use GWC tiles directly from the WMS URL, you need to provide a tiled=true parameter in the request.

The Tiles will be gnerated in two cases:

  • Either you hit the GWC URL (directly or via the tiled=true parameter in the WMS request)

  • or You seed the tile sets

To consume the tiles, you have to use GWC, via the URL or via the parameter in the WMS service

  • Thank you very much for this. Its easy fix ... Just need to modify the url in the WMS call. THX !!! – Alophind Jan 28 '14 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.