4

I am new to QGIS, and this is a very basic question.

I made a new polygon layer, to trace cadastral boundaries off a raster map. I want the polygon nodes on adjoining acreages to snap together. Some do because I have 'avoid intersections' on. But if I have to manually move a node on one polygon onto a node on the adjoining polygon, I cannot get it to snap to it. I've read the manual, tried to sort it out, but I cannot make it work. How do I make it work? Refer to the screenshot.

Cadastral boundaries won't snap together

I have used MapInfo for 14 years. It does not have an inbuilt way to avoid polygon overlaps, but its snapping is very straightforward.

  • What steps have you taken so far? – Nathan W Jan 28 '14 at 9:27
  • 1
    As above steps and details. Have you set your tollerances in snapping options? – Ger Jan 28 '14 at 9:42
  • Tolerances in Snapping Options ... hey, that was the problem. Now it's working. Many thanks. – IanS Jan 28 '14 at 10:24
  • To clarify - In Snapping Options I set the tolerance to 6 pixels (it was set to 0 initially). I can now see a magenta 'plus' sign appear over the node when it is in snap mode. – IanS Jan 28 '14 at 10:33
  • You could move your comment to the "answer your own question"-box below. – tobias47n9e Jan 29 '14 at 16:44
4

To close this off. I'll provide my own answer as per commentator's suggestion.

To recap, I could not get nodes on adjacent polygons to snap together when I hovered one node over the other. It turns out that the tolerance was set to zero by default.

In Settings - Snapping options, set the tolerance to 6 pixels (see screenshot). A magenta 'plus' sign appears over the node when it gets in range to snap to another node. After experimenting a while now, I think this is a good value to start with on any project.

Ensure the snapping tolerance is set to a sensible value

  • While I have done this, I'm still getting plenty of topological errors. – Geosphere May 25 '15 at 11:06
  • More experience has led me to use a tolerance of 12 to 15 pixels these days. If you try that, does that solve your problem? – IanS May 25 '15 at 11:41
  • Not really. Apparently, I'm getting overlaps. Interestingly enough, I do not recall having this many issues while using ArcGIS. – Geosphere May 25 '15 at 12:23
  • However, I must mention that I do get fewer and the geometry is fine, just some overlap here and there. – Geosphere May 25 '15 at 12:28
  • Have you checked both "Enable topological editing" in the snapping options, and also "Avoid Int." (Avoid intersections of new polygons) in the snapping options for the layer you are editing? (as per screenshot in answer above) – IanS May 25 '15 at 12:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.