One of my coworkers emailed me about some issues with opening .mxd files in ArcMap 10.2, and through further questioning she revealed it actually started when she updated to 10.1 and has continued after her update to 10.2. Apparently when certain mxd files are opened (I'm guessing ones that were created before her upgrade to 10.1) in ArcMap it crashes with an error (fig. 1). If MXD doctor is run on the files they then work fine, I have attached the Diagnostic Report(fig.2).I thought maybe if they are just older 9.xx documents this could be the culprit but I read that those mxds should still open but will just be saved as 10.x map docs. Any idea looking at the errors what the problem may be?



  • 1
    Any idea what ArcExtDomain.dll is? Not sure, but I don't think this is an Esri dll. Is it a custom extension? Commented Jan 30, 2014 at 20:07
  • No clue its possible it is a custom extension as my department does have a few. Commented Jan 31, 2014 at 14:10
  • 1
    I suspect that this custom extension is the root of the problem. Specifically, if you have the source code to the extension, make sure it's not doing much in IExtension.Startup other than subscribing to document events. Commented Feb 1, 2014 at 22:43
  • 1
    Uninstalling arcgis does not uninstall custom extensions. You'll need to do that yourself. The version of ArcExtDomain.dll is 10.0, whereas ArcGIS is at 10.2. Commented Feb 1, 2014 at 22:47
  • 1
    If you go into add/remove programs, is there an entry for Image Analysis for ArcGIS? You might be able to uninstall it from there. More likely though, the uninstallation will fail, since the uninstaller requires 10.0 to be present. Which means you might need to uninstall 10.2, reinstall 10.0, uninstall Image Analysis, then re-install 10.2. I sure wish Esri's uninstaller provided an option that would uninstall 3rd party extensions. Have you checked with Erdas for an update? I don't have that dll in my C:\Program Files (x86)\ArcGIS\Desktop10.1 folder. Commented Feb 4, 2014 at 16:55

2 Answers 2


The first step is to always clear your application profile. If other users aren't having the same errors with those MXD's, that is a clear indication that the profile for the bad install is corrupted in some way.

Follow the instructions at this helpful thread, but mainly you need to rename C:\Users\\AppData\Roaming\ESRI (or another folder if you aren't on win Vista/7/8)

  • Do you think if I have her send me one of the map docs causing the crash I could test to see if it causes an error on my system even if I don't have the data the map doc references? Commented Jan 30, 2014 at 18:08
  • That's a good idea to check to make sure it isn't just the MXDs that are causing problems, but having issues related to the application profile (that require it to be reset) are fairly common.
    – DPierce
    Commented Jan 30, 2014 at 18:31
  • I tried the MXD it worked fine on my system instructed her to rename the ESRI folder but it didn't fix the problem, I still think it points to a bad install though I'll have her reinstall and see if that works. Commented Jan 31, 2014 at 14:13
  • The link to the thread is not working anymore, so here is the new one: community.esri.com/thread/78692
    – maycca
    Commented Oct 17, 2017 at 16:30

I have found this issue to be related to broken data source paths, (possibly specific to SDE connections). To get the old mxds open:

  1. Open ArcMap
  2. Disable Network or pull the network cable
  3. From ArcMap, Open the old mxd - should open with all layers sources broken
  4. Enable Network or plug in the network cable
  5. Fix the broken data sources
  • Unfortunately I am no longer at this job to test this but maybe future users will be able to try this solution out. Commented Jun 10, 2016 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.