0

I was able to login as

http://<domain_name>:3000

Done some import jobs, publish the map, copied the API link to a sample HTML page. Able to view the whole base map and CartoDB layer from local. But I tried from other network, the CartoDB layer seems to be not seen. Checked the console, but no errors where logged. Edited the development.js from the Windshaft directory and changed the localhost instances to domain name, and also the app_config.yml files.

1

The local system browser knows about your domain just because you've added an /etc/hosts entry pointing domain to your localhost.

I see two ways for you to see your cartodb from a remote network:

a) accessing your computer using it's public IP, like this: http://public_ip:3000

b) having access to your DNS server and inserting Address records for your domain and for your subdomain, like this:

NAME                    TYPE   VALUE
--------------------------------------------------
domain.com              A      public_ip
subdomain.domain.com.   A      public_ip

This way, you'll be able to access your machine from remote using http://domain.com:3000

See also, this link.

  • I am been able to access cartodb dash board from remote using http://<domain_name>:3000. But still not able to load a layer, that is rendered using cartodb, from remote. I have using cartodb.createLayer(mapObject, cartoframeLayerURL ,{no_cdn: true }) to create layer. – varun Feb 3 '14 at 7:26
  • How looks your cartoframeLayerURL? Is something as domain.com:3000 or subdomain.domain.com:3000? – Sorin Călinică Feb 3 '14 at 8:30
  • http://<sample>.no-ip.biz:3000/api/v2/viz/769ed96a-8c9e-11e3-a26c-dc0ea16343f8/viz.json – varun Feb 3 '14 at 11:14
  • Did you have a firewall blocking the 3000 port on your "server"? Did you tried to disable it or adding a passing rule? – Sorin Călinică Feb 3 '14 at 11:30
  • port forwarding is done for port 3000. – varun Feb 3 '14 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.