0

I have encountered an error in how ArcGIS Desktop displays a Raster file (.TIF format) at different scales. At scales greater than 1:3,76,600, when I'm zoomed in, the raster displays mostly correctly, showing only a border of low-value cells, or no border -the "border" appears inconsistently. (first picture)

enter image description here

What is consistent is that when I zoom out, specifically when I go from 1: 3,000,000 to 1:4,000,000, the white background (correctly indicating no-data cells) change to blue (indicating the lowest value "bin" in the classification). When I check the cell values, the cells are NoData value, even when zoomed in and blue (and they should be clear). (second picture)

enter image description here

Any suggestions?

I want to display this data zoomed out to a scale smaller than 1:3,000,000 but it is falsely visualizing the data. I am working in ArcGIS Desktop 10.2 with all licenses installed. In Layer Properties > General Tab > "Scale Range," "Show layer at all scales" is checked.

  • Can you specify upon the raster dataset: Is it a 1 channel 8bit raster, or are you displaying a RGB image? How do you assign the yellow and the blue colors? – lavarider Feb 4 '14 at 17:03
  • 1 band, 64bit pixel depth. It is an enormous raster, 1665 columns and 2480 rows. Looking again it does say NoData Value = -1.7e+308, instead of either of the "more" correct options of 0 or NoData. – SharonB Feb 4 '14 at 17:55
  • You can re-assign the NoData manually if you don't like -1.7e308. Do this in ArcCatalog: Browse to your raster and open its Properties from the context menu; There is an edit button next to the "NoData" field, change NoData to any unused value (e.g. 0?). I assume the 64bit data type is intentional - if not, I highly recommend to re-calculate your raster. If you are dealing with integers, you should also move away from floating point to an integer data type: Although any data type and any NoData value will work, the discussed pyramid issue is more likely with a floating point raster. – lavarider Feb 4 '14 at 20:16
  • by the way, your NoData value is -1.7e+308 because this is the max double (negative) number of 64bit floating point encoding. Wikipedia has some examples about that. – lavarider Feb 4 '14 at 20:26
4

I sometimes encounter similar errors, especially if the raster values repesent some non-continuous data (like classifications). This is probably related to pyramids which seem to not fully respect nodata values in some cases.

There are two possible workarounds:

  • Rebuild the pyramids of your raster data. For classification rasters, you should use Nearest Neighbor technique (interpolating makes no sense there). You can also clear the pyramids (i.e. set pyramid level to 0) if re-building pyramids has no effect. The raster is then displayed without pyramids - this may slow down its display depending on your raster size. For small rasters, you may well go without pyramids. (I tend to turn off pyramids for classification rasters)

  • Manually assign a display color of your NoData value for each raster image.

  • lavarider, thanks for your comments and answers. I will attempt to both rebuild pyramids as well as set the pyramid level to 0. For now, though, I would note that I have manually assigned NoData to be transparent....this makes me think you are right about the lack of pyramid respect. – SharonB Feb 4 '14 at 17:57
  • Hmmm. When I tried rebuilding the pyramids using the Geoprocessing> Environments > Raster Storage settings, nothing changes. – SharonB Feb 4 '14 at 18:07
  • ah-ha! instead of working only in the Geoprocessing menu options, I used the Build Pyramids tool (Tools> Data Management) and set the Pyramid Levels = 0, as @lavarider suggested through the suggested links in their answer. It appears the raster is now correctly showing NoData cells with no color. – SharonB Feb 4 '14 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.