I have downloaded QGIS dev version 1.7.0-114 and I have come across some weird behaviour in the composer.

I create a map with a hillshade and a transparent DEM ontop of it, pretty standard stuff. When I export this map to an image format I get two strips across my output, this happens for a number of formats (png, jpg, bmp, tiff) and the stripes seem to be in the same place everytime. I have attached an example below (sorry for the size of the attachment).

enter image description here

The stripes appear in the same position on the page every time and this happens with different raster datasets, so I have ruled out the data.

Also depending on the page size you may get 1 stripe (A5 as shown above), 2 stripes (A4) or no strips (custom dimensions h100 x w100).

Is this something that can be overcome via some settings which I may have overlooked? Or might this be something funny in the software?

  • not a QGIS guy but at a first glance this appears to be a video card/driver issue. does this happen on a different computer? update drivers and try again, just a thought. (have similar issues with exporting to image in other software and it is video card related) Commented Apr 15, 2011 at 1:46
  • hmmm that is strange. I have never seen that happen before. I'll try and replicate on my machine.
    – Nathan W
    Commented Apr 15, 2011 at 2:40
  • Thanks Nathan, let me know how you go. I went home at lunch time and tried on my lappie (running Ubunutu 10.10) and it worked fine. Wonder if its the video card related like Jakub mentioned or a Windows related?
    – Ando
    Commented Apr 15, 2011 at 2:58
  • Should be fixed in next release or go to trunk - hub.qgis.org/issues/5133
    – Willy
    Commented Aug 20, 2012 at 10:40

1 Answer 1


This same question came across the QGIS user email list last week. http://lists.osgeo.org/pipermail/qgis-user/2011-April/011691.html

Any idea, why a narrow band appears after saving/exporting from print composer?



it was logged about a month ago @ http://trac.osgeo.org/qgis/ticket/3640

  • Thanks Ryan. I wonder why this isn't happening on my Ubuntu install? I have only experienced this on my work machine which runs windows 7.
    – Ando
    Commented Apr 15, 2011 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.