9

I have a project which uses WMTS and some vector layers in QGIS. I can freely zoom in and out, and tiles are refreshed with appropriate zoom level, just as expected.

Now I would like to export part of this map (a given bounding box) with the tiles at a fixed zoom level, so that I can better match the printer resolution when map is printed in the desired physical size.

How should I tell QGIS to use that given zoom level, and which file format is best suited to do what I want?

  • having the same problem, as I need the more detailed zoomlevel on a large format print. I will try to download the tile cache with MOBAC and then somehow only load the zoomlevel which Im interested in, but I dont know if I will be able to georeference the tiles correctly when I load them each one separetely... – Jürgen Zornig Feb 26 '14 at 13:32
  • Same issue for me. The interaction between Print Composer and a WMS service results in the use of tiles of a given zoom level - usually too detailed for the physical page size. I need to tell QGIS Print Composer to use a different zoom level for the tiles. Have tried work-around by first 'printing'/exporting to a pdf paper size smaller than I need then re-printing this pdf magnified. This is OKish for a physical print by myself, but I'd also like to save this as a correct-size pdf or jpg for others, and if I do this the process of re-saving the image means the quality drops below acceptable. – Rostranimin May 21 '14 at 9:02
  • 1
    Have discovered in the last few days that Composer's resolution setting has an effect on the choice of tile zoom level, but unfortunately to get an appropriate zoom level seems to involve setting the resolution unreasonably low - creating other issues I think. There must be a way around this... – Rostranimin May 26 '14 at 19:39
2

This existing ticket seems closest to the issue (even though it mentions the OpenLayers plugin instead of WMTS): #11106 WMTS Zoom Level Tied to Export Resolution when Exporting from Print Composer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.