I am not a "computer person". So -- I don't know what this error message means. I found this question and answer for this same problem, but the solution did not work for me, dammit. GRASS algorithm r.los does not produce raster

I am using QGIS 2.0 (or maybe 2.0.1?). The computer is running Windows 7. I activated the menu Processing > Commander and got the command entry line above the map-area window -- no problem there. (The QGIS project I'm using has an elevation raster.) The computer program picks up just fine that I want to use the loaded raster. I copy and paste my coordinates for viewer location just fine. I tried leaving the default, temporary output file, and I also tried creating and entering into the GUI form a new file for this process. Each time, the following error message resulted.

Oooops! The following output layers could not be open
Output raster layer: C:/Users/Cogreg/Documents/GIS, QGiS/Files_Greg_created_via_GIS/300_CountyRd_41_viewshed.tif
The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm
Checking the log information might help you see why those layers were not created as expected
This algorithm requires GRASS to be run. A test to check if GRASS is correctly installed and configured in your system has been performed, with the following result:
GRASS seems to be correctly installed and configured
  • 2
    I tried to format the error. Can you confirm there really is a comma-space pattern in the filename? Can you try saving it to somewhere that doesn't have this pattern (like C:\Users\Cogreg\Documents\test.tif)? – BradHards Feb 11 '14 at 2:06

The output layer could not be opened because it could not be created. So it is not a read output file error. Check the extensive processing log for errors. For info on the processing log see no output file with grass:r.los. I have on occasions crashed r.los from Processing framework implementation when the dataset bound was not set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.