3

We have created a map service using version 10.2 from a map which all layers data source are point to an SDE connection service using DB2 database. However, the coded value domain not appear in the REST service.

Then, we tried to make a new map and add few certain layers using same SDE and I don't why the domain values appeared. Then, we tried to add another layer, republished the map service, and suddenly the coded value domain are gone even the previous ones that suppose has it.

We even tried to move certain layers up and down in TOC, republished the map service, and it seems like the coded value domain sometimes appear and sometimes not..depends on layer order. We've checked all feature tables subtype fields and all has values and not NULL.

Previously, we created the map service using ArcCatalog 10.0 and it worked fine. all layers has coded value domain in its REST service using the same map only the SDE is version 10.0.

Summary: using ArcCatalog 10.0, SDE version 10.0, published map service, coded value domain appeared. But, using ArcMap 10.2 (cannot use ArcCatalog 10.2 to publish map service no more), SDE version 10.2(we even tried to use ODBC direct connection), published map service, coded value domain not appeared (well, depends on what layer and layer order??)

Thanks for your helps.

  • i am experiencing similar. ever get an answer? – VBAHole Aug 5 '14 at 18:14
  • Similar issue here. Any solutions? – user37914 Oct 7 '14 at 21:20
  • I believe the answer below may have helped many with this issue, and the 10.2.2 sub-release increased the default value of this limiting env. variable. Please confirm by selecting the answer as correct to close this question. – JasonInVegas Dec 3 '14 at 18:19
1

I had the same issue and was able to solve it.

If You have large number of layers or domains with many values then service may reach "Maximum Number of Coded Domains" parameter maximum value.

  • Go to "ArcGIS server manager"
  • "Edit service" (the one with missing domains)
  • Open "Parameters" settings
  • "Properties" table find the "Maximum Number of Coded Domains" parameter and drastically enhance it
  • press "save and restart".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.