I am using QGIS 2.0 and when I try to create my map in the print composer, I cannot make the scale and the extent the way that I need it.

I need my map to be at the scale of 1:10 000. However, the map area is quite large and I need a specific x min and y max in the extent (the x max and y min do not matter). I also need a full A4 size sheet of paper.

When I enter the scale in, the map extent is not where I need it. If I change the extent, it either changes the scale of the map or changes the size of the map canvas in the print composer. When I change either one of those back, the scale changes and so on and so forth.

Is there some way to lock the scale and then just move the map image inside the map canvas?

1 Answer 1


The scale will inevitably effect the extent for any given area and that will be limited by the size of your paper (so an A4 sheet @ 1:50,000 scale will be approximately a half of the possible extent of an A3 sheet). Contrariwise, setting the map extent for a given area of paper will also inevitable dictate the scale. You cannot adjust one without influencing the other (which is why you have received some negative scores for this question).

You have stated that your actual extent is not as important as scale. So to resolve your dilemma, set the scale and then, with the map selected, click the 'Move item content' button (icon is a small arrow and green box, next to the 'Select/Move item' button - a large arrow).

enter image description here

You can now 'slide' the content of the map without changing the position of the map on the page and thereby center you map contents on your area of interest.

If the extent of the map is still not large enough at the scale you must use, then you need to increase the size of the map and that might mean splitting your map over two or more sheets and to do that effectively you can use the Atlas generator.

  • I knew there must be something I was missing! Thank you!
    – nwoodworth
    Commented Feb 16, 2014 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.