1

i've created script using arpy with arcgis 10.1. One of the goal is to clip raster via shp file, which contains one feature. it worked perfect.
after migration to arcgis 10.2 i've noticed some problem. result of clipping raster in exact shape of feature. it is just clip to extent of clipping feature.

arcpy.Clip_management(inFC, "#", cut_director + "/" + outFC, shp + "/" + shp_clip, "#", "ClippingGeometry")

i've tried to do clipping via arctoolbox (it does the job) and then copy the process as python snippet but after changing input, output and clipping feature i received error.

thanks in advance for help

edit: i've found answer. when change nodata parametr from "#" (second one in code above) to "256" it works.

  • Please consider adding your solution as an answer, so that this question can be considered resolved. Thanks. – Aaron Feb 14 '14 at 15:01
1

I could solve the issue.

I just has to change the nodata parameter from "#" (second one in code above) to "256".

After doing this, the code works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.