I am using ArcGIS 10.1, most recent service pack/patch, and on Windows 7 with 8GB RAM

I always run Models from ArcCatalog

I have a model that validates and runs from the "edit" window.

When I run the exact same model with the exact same input data, but from the "open" window it returns error messages.

Do you have any experience or advice to share over this issue?

Are there certain tools or processes that can cause this issue?

The issue that occurs most frequently is with the Focal statistics and the Get Raster Properties Tools - when the model is run from the Open window these tools can fail because the preceding data does not have valid statistics. It is unclear why the model runs OK (with exact same data) from the edit window. Surely this should be picked up by the model validation process?

The errors that occur are

ERROR 001100: Failed because no statistics are available.

The solution can be to add in "Calculate Statistics" tools into the models, however the behaviour appears erratic and this solution has occasionally not worked, even on the same model , same data, same computer.

One of the models that runs OK from the edit Window, into which I have added the Calculate Statistics tool, return the following error only when run from the Open Window.

ERROR 999999: Error executing function. The workspace is not connected. Failed to execute (Calculate Statistics).

Any ideas/thoughts?


2 Answers 2


Whilst preparing this data to send off to ESRI support I did a quick test of copying and pasting the whole model into a new blank Model.

The model now works OK from both Edit and Open windows without adding in any extra Tools / processes.

However this issue - as explained above - happens so frequently that I would be very interested to hear from anyone else reporting similar issues.

For now I have not included the additional "calculate statistics" tools in my model, it remains unclear if the occurrence of these errors messages, and the different behavior between the Open and Edit window is a symptom of an unstable model that is resolved, or if it will re-occur.


I think that the problem comes from the type of input. In edit you probably drag-droppped a raster layer, but when you open it it could have been a raster dataset. This could explain why the statistics are not properly identified. Try selecting a layer (drop down arrow) instead of a dataset (navigate directory).

In you model, you could use the "make raster layer" and the "calculate statistics" to make sure that your data is read in the best possible way. If your data is of integer type, you can also "build raster attribute table".

  • thanks for your reply. the input data is a feature class, which is converted to a raster part way through the model. also the model parameters are saved, along with their file paths (relative) so the model always opens pre-populated with the correct data inputs.
    – user21053
    Feb 17, 2014 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.