2

Does anyone know what the latest version of R that supported the gpclib package? I was using the latest version but when I tried to install gpclib, it said that it was unable due to my version of R. The gpclib page gives the minimum version and requirements. Do I have to downgrade my version of R?

5
  • What version of R are you using? R --version
    – Curlew
    Feb 17, 2014 at 20:59
  • 3.0.2 plus 10 chars for so
    – mdsumner
    Feb 17, 2014 at 22:55
  • 1
    Do you have to use gpclib? Due to its license restrictions the functionality has now being replaced by rgeos. I would suggest using rgeos rather than downgrading R.
    – cengel
    Feb 18, 2014 at 17:56
  • It is a for a homework assignment and right now I am not familiar enough with R to change any of the steps. I will take note for future assignments; this is very helpful. Thanks you guys.
    – geomatix
    Feb 18, 2014 at 21:44
  • @Jeffrey Evans, can you post your comment as the answer? This is a great reply and I will accept it as the answer.
    – geomatix
    Feb 18, 2014 at 22:22

2 Answers 2

1

I would echo @cengel, gpclib is depreciated and replaced by rgeos. Why do you think that you need it? By default, functionality in maptools that depended on gpclib has been updated to utilize rgeos. You can however, still force gpclib.

But to answer your question, yes you would need to revert your R version to <= 2.15 to have access to gpclib binaries under windows. However, keep in mind that, in doing this, you loose a number of improvements made to the spatial packages in both speed and functionality.

1

gpclib just depends on R ≥ 2.14.0.

But there are no Windows binaries on CRAN (see here):

Packages

RSvgDevice, RSVGTipsDevice, StreamingLm, TwoPhaseInd, eco, gpclib, ifa, translate

are not checked nor distributed due to crashes under Windows or extremely unstable check results that switch forth and back between OK and ERROR or WARNING.

2
  • I'm still new to R and new to StackExchange for that matter so I'm unsure how to interpret your answer. Do I need to downgrade and if so by how much?
    – geomatix
    Feb 18, 2014 at 16:58
  • R version 2.15.3 "Security Blanket" installed gpclib without any errors.
    – geomatix
    Feb 18, 2014 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.