4

I installed QGIS, GRASS and GDAL by OSGeo4w package, and as I finish the installation, I want to use GRASS tool, I face this problem:

enter image description here

But I already installed GRASS and SAGA, how to make those tools in QGIS to be used?

  • 1
    Have you checked the files at C:\OSGeo4W\var\log to see that the setup ran without errors? – AndreJ Feb 18 '14 at 8:04
  • I have these errors:1. 2014/02/18 12:31:49 io_stream_cygfile: fopen(/etc/setup/setup.rc) failed 2 No such file or directory, 2. 2014/02/18 12:31:57 io_stream_cygfile: fopen(/etc/setup/installed.db) failed 2 No such file or directory 2014/02/18 12:31:57 io_stream_cygfile: fopen(/etc/setup/timestamp) failed 2 No such file or directory, 3. 2014/02/18 12:43:03 error: Environment variable 'PATH' length exceeds 1024; running with %WINDIR%\system32;%WINDIR%;%WINDIR%\wbem – Heinz Feb 18 '14 at 8:30
  • 1
    The last error has to be solved. You have to clean up your PATH variable. Have you got a GRASS icon on the desktop? In QGIS, Processing -> Options -> Data Provider -> GRASS, is it activated, and is the GRASS folder path correct? – AndreJ Feb 18 '14 at 9:17
  • 1
    Apart from Windows entries, all you might experience is some other programmes may not run afterwards. Creating a recovery point might be a good idea. You have to reinstall QGIS after that to run the installer successfully to the end. – AndreJ Feb 18 '14 at 10:38
  • 1
    With QGIS 2.2 just around the cormer, I suggest to wait for that new version. – AndreJ Feb 21 '14 at 5:06
4

You need to configure the GRASS and SAGA folders in QGIS. Follow these instructions from the QGIS documentation on Configuring external applications:

The processing framework can be extended using additional applications. Currently, SAGA, GRASS, OTB (Orfeo Toolbox) and R are supported, along with some other command-line applications that provide spatial data analysis functionalities. Algorithms relying on an external application are managed by their own algorithm provider.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.