1

I am trying to publish an OGC WMS service to my Flex Viewer. Within the configuration files amongst a few other layers I have the following:

        <layer label="EARSS National Outage Map" type="wms" visible="false" visiblelayers="earss:national_outage_map" skipgetcapabilities="false" alpha="0.6"
                autorefresh="60" 
                url="https://earss.extranet.ornl.gov/geoserver/ows?service=wms&version=1.1.1&request=GetCapabilities/obs?srs=EPSG:4326">

The service does not appear within the TOC of the viewer. I tried the trick of creating "a service with a service" and that did not work.

1

hi you are using wms as a service but you are using wfs methods in your url so u have juste to change ur url and it will work

Ex: url="http://localhost:8080/geoserver/workspacename/wms?service=WMS&version=1.1.0&request=GetMap&layers=entrepot:layername1"

1

url=https://earss.extranet.ornl.gov/geoserver/ows?service=wms&version=1.1.1&request=GetCapabilities/obs?srs=EPSG:4326

The WMS URL is incorrect, it should point to the service endpoint and not contain any parameters.

Take a look at the ArcGIS Viewer for Flex documentation. Your layer information should look like:

<layer 
  label="EARSS National Outage Map" 
  type="wms" 
  visible="false" 
  alpha="0.6"
  url="https://earss.extranet.ornl.gov/geoserver/ows"
  visiblelayers="earss:national_outage_map"
  imageFormat="png"
  skipgetcapabilities="false"
  version="1.1.1"/>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.