7

A similiar question has been asked recently as How to make GRASS and SAGA tools capable to use in QGIS?

However I have some specific queries and process I have tried which are probably better in a new question for clarity.

The process I used is as follows:

  1. Installed QGIS using OSGeo4W. Installed Dufour 2.1 under Program files. Apps directory shows saga_gui.exe (2.0.8). Grass plugin working ok. Install looks ok.
  2. The SAGA instructions mention a configuration dialogue without being a bit more accurate. https://www.qgis.org/en/docs/user_manual/processing/3rdParty.html. I assume this is in QGIS Settings \ Options \System variables, and that you should be able to put in the path to the .exe? If so I cannot seem to get this to work. Or maybe it's somewhere else.
  3. Also mentioned is that SAGA 2.1 is needed. I've downloaded this and, as it appears to be a "standalone programme", put the whole thing into the Dufour folder rather than reinstalling everything with the aim of configuring the path to the .exe from QGIS. Is this correct, as usually installs put files all over the place?

From my quick look at the program SAGA seems to look pretty good. However there appears to be only basic file support (dxf, txt, etc) and no ability to directly load MapInfo files which is what I was interested in.

How do I run it from QGIS?

1
  • A resposta de Florian Brucker foi a que funcionou para mim. Thank you, Florian! Mar 9, 2021 at 15:20

5 Answers 5

7

On my installation of QGIS 3.10.4 on Ubuntu 20.04 I had to install SAGA manually via

sudo apt install saga

After restarting QGIS, SAGA was then listed in the processing toolbox.

5

SAGA and the other Processing modules are configured under Processing -> Options and Configuration -> Providers.

From QGIS 2.0 onwards, SAGA should come with the QGIS standalone installer, so no need to install and configure it manually. I still use the 32bit version, maybe there are some bugs in the 64bit installation routines.

It might help to search the installation protocol postinstall.log for error messages.

If you used the OSGEO4W setup, all installations should go to C:\OSGEO4W or C:\OSGEO4W64; including SAGA and GRASS.

2
  • I am unable to find Krigging algorithm in QGIS 2.14 over Ubuntu but those were available o QGIS 2.18 over windows . Is it anyway related to version ?? Also there are no options available in processing toolbox for SAGA in ubuntu (In providers it is activated)
    – sudhanshud
    Sep 17, 2017 at 13:55
  • I have SAGA kriging in Ubuntu as well as Windows, 2.14 and 2.18. On Ubuntu, You have to install SAGA manually.
    – AndreJ
    Sep 18, 2017 at 5:47
3

Try this: in the Processing -> Options -> Providers look for SAGA (2.1) and check Enable Saga 2.0.8 compatibility.

Worked for me on Ubuntu and Win8

8
  • 1
    Thanks folks but at the risk of sounding dense, where is the Processing \ Options \ ... command located?
    – DirkB
    Feb 20, 2014 at 6:27
  • After enabling processing plugin you should have Processing or Geoprocessing menu - somewhere after Raster and Vector etc.
    – mrz
    Feb 20, 2014 at 6:32
  • Cheers. Lesson - ensure Processing ticked in plugin so it displays. All ok and saying activated but no sign of it on menu bar or anywhere in panels/toolbars. I note that the OSGeo4W is in different directory to Dufour installation. Can't remember if I did a manual install of Dufour. Is this an issue?
    – DirkB
    Feb 20, 2014 at 7:05
  • 1
    OSGEO4W and standalone Dufour are two different worlds. They only share the same python plugins in /.qgis2.
    – AndreJ
    Feb 20, 2014 at 9:01
  • 2
    I am having the same problem with QGIS 2.2 on Ubuntu 12.04. I've upgraded QGIS to 2.2 today and I installed SAGA 2.1. When I go to Processing -> Options -> Providers -> SAGA, I don't see any setting for "SAGA folder"! And when I try to run a SAGA algorithm from the processing toolbox, I get an error "This algorithm requires SAGA to be run.Unfortunately, it seems that SAGA is not installed in your system, or it is not correctly configured to be used from QGIS." Feb 26, 2014 at 10:13
3

I had the same problem and solved it by reinstalling QGIS 3.4.1, 3.0.1 ltr, SAGA 2.3.2 and 2.122 ltr all together from OSGeo4W shell.

2

I had the same problem when enabling SAGA.

I found out that in order to see SAGA I had to open Processing \ Options and activate all the providers elements, reset the location of the SAGA folder AND click at the bottom of the toolbox menu : Advanced Interface instead of Simplified interface!

Now it's working!

3
  • What do you mean by "reset the location of the SAGA folder"?
    – GStav
    Nov 28, 2017 at 11:10
  • @Stéphanie Morin, can you specifiy what you mean by 'reset the location of the SAGA folder?'
    – GBG
    Dec 18, 2019 at 3:38
  • Providing the path solved my issue! You can get there via: Settings > Options > Processing > Providers > SAGANG > SAGA folder. I provided the default installation directory - e.g. C:/Program Files/QGIS 3.34.3/apps/saga9 - and the SAGA toolbox appeared,
    – dimfalk
    Feb 29 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.