1

I am a beginner with Geoserver. I have started reading the Boundless tutorial: introduction to Geoserver.

In the very first step, for installing the OpenGeo Suite and running the welcome page of Geoserver I have faced an error.

The error states: 404: Not found The requested URL /geoserver was not found on this server

I received no errors during the installation phase.

when I try to run

http://localhost:8080/

I receive a logo of EnterpriseDB and some texts as follow:

Apache - version 2.4.7 PHP - version 5.4.23 Server is up and running The default Apache context is www in the Apache installation folder

I've checked the instructions for windows installation from here: http://suite.opengeo.org/docs/installation/windows/misc.html#installation-windows-misc

were it is stated that perhaps if the port used by Jetty web server (8080) is already used by another service, we can configure and change the port information. For this they mention to look for a file located at: C:\Program Files\Boundless\OpenGeo\bin\jetty\start.ini

Where I don't actually find such a file. I can locate the bin folder in OpenGeo, but there is no "jetty" folder in "bin". I've tried stopping and starting the services, all performed with no error/message. I've tried re-installing OpenGeo Suite (even in different location than Program files path). Still have the same error when trying to load

http://localhost:8080/geoserver

Does anybody have suggestion to fix this?

I have installed OpenGeo Suite 4.0.2 on Windows Server 2012 R2 Standard.

Thanks

  • try localhost:8080/geoserver/web – Ralph Dell Feb 20 '14 at 14:20
  • Shows the same Error:404 Not found – Catlover Feb 20 '14 at 14:23
  • Seeing the Enterprise logo on localhost:8080 tells you that apache web server is running on port 8080. I do not run OpenGeo Suite. Was apache installed with OpenGeo? Normally webservers run on port 80. – Ralph Dell Feb 20 '14 at 14:31
  • can you especified where can i find the 'Products tab and selected the Frameworks tab ' thanks! – Lara Della Ceca Dec 11 '18 at 1:05
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Vince Dec 11 '18 at 1:50
1

Looks like there is a bug in the docs. The path should be: C:\Program Files\Boundless\OpenGeo\jetty\start.ini.

  • Already changed the port number in this file. The problem still remains. Do you have any other suggestion how to fix it? – Catlover Feb 21 '14 at 14:01
1

Ok. With some searching I figured how to solve the problem. Hope it helps others as well!

First I downloaded the Microsoft Web Platform Installer and run it on my server. then I navigated to the Products tab and selected the Frameworks tab on the left side. From the list I found and Checked the PHP option. Then clicked Install! Easy as it sounds!

Thanks to all who tried to show me the correct path!

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.