1

I am using GRASS 6.4.3 (installed with osGeo4w), and I have this question:

As I type g.list, a function window will pop out, and all functions and results are fine. But when I type g.list rast, I got this message:

'%GRASS_PAGER%' is not recognized as an internal or external command, operable program or batch file.

The photo below, left one is the correct output in popout window as I type in command g.list, and the right one is the message I got in command line as I type in g.list rastenter image description here

But I have already add the following paths in my path environment variables:

1. C:\OSGeo4W64\apps\grass\grass-6.4.3\bin
2. C:\OSGeo4W64\bin

How can I solve this problem? I am using GRASS 6.4.3 under windows 8.1 64-bits, please give me any suggestion!

  • 1
    I'm glad I was able to help you. Please add a comment to my answer with a short description how you finally solve the problem! – Stefan Feb 25 '14 at 8:50
  • @StefanB. thank you and I will try to look at references you gave me – Heinz Feb 25 '14 at 9:29
1

Just try the following:

g.list type=rast

or

g.list type=vect

Besides you can use g.mlist type=rast for (I think) a better look on your raster/vector files.

Update

Maybe there is a problem with your installation. Take a look at this manual for compiling grass under windows (look for the msys-grass) and further information here.

Additionally you can try to use grass in MSYS.

  • 1
    I have tried g.list type=rast and g.list type=vect and got the same result, but as I tried g.mlist the results were fine. Why can't I use g.list command? – Heinz Feb 22 '14 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.