During the past weeks, I have tried QGIS to recognize SAGA via the processing toolbox, both being installed from the ubuntugis-unstable repository.

I have tried this on several virtual ubuntu operating systems which I specifically set up for using QGIS. However, I always get the same "Missing dependency.This algorithm cannot be run" (sic) error message. Here's some more information:

  • I have tried (l)ubuntu 12.04, 13.04 and 13.10 (each 64bit), installing packages from the respective repos. I
  • I am now an ubuntu 12.04 32bit VM
  • I am well aware of this post, and yes, this workaround would do the trick! However, installing from the qgis repositories is not an option for me, as I also need the orfeo toolbox packages, which are not provided there :(
  • Package versions are qgis 2.2.0-1, saga 2.1.1 and python-saga 2.1.1. I had the same problem with the preceding QGIS version.
  • I checked the PATH variable and successfully launched saga_cmd, so everything seems to be in its place.
  • I suppose it could be possible to install QGIS like it was described in post you mentioned, and then install OTB from another repo or from source. Commented Feb 24, 2014 at 11:03
  • I have this Problem as a recurring issue on my Ubuntu Precise with multiple users in multiple groups. In my case, the Problem is that /tmp/processing gets created by userA with ownership and no write Access outside the Group. If I fix the permissions on /tmp/processing with sudo chown root.root /tmp/processing and sudo chmod 0777 /tmp/processing, then saga (and grass) will work fine. Don't know if that's your Problem, though. Commented Jun 12, 2014 at 9:33
  • Same problem here, no solution. Commented Jun 17, 2014 at 1:11
  • Which algorithm are you trying to run?
    – johanvdw
    Commented Jul 3, 2014 at 19:53
  • I have QGIS 2.4.0, SAGA 2.1.2 on Kubuntu x86_64 4.13.3, and the same problem. No idea why. @johanvdw, I've tried clicking on all the kriging algorithms and the "Reclassify grid values" algorithm. Seems like it doesn't matter which one you try, QGIS says it cannot find SAGA. Commented Sep 24, 2014 at 15:00

3 Answers 3


Another Thing to try:

  1. Go to Processing->Options and Configuration
  2. Click on Providers->SAGA
  3. Uncheck "Enable SAGA 2.0.8 compatibility"

I also had the same problem. Found out I was using an outdated version of SAGA GIS 2.1.0 that was not supported.

If you want to know which version of SAGA GIS that any version of QGIS supports. Check this line

 supportedVersions = {"2.1.2": ("2.1.2", SagaAlgorithm212),                    
                     "2.1.3": ("2.1.3", SagaAlgorithm213),                    
                     "2.1.4": ("2.1.3", SagaAlgorithm214),                    
                     # to allow testing upcoming release                      
                     "2.2.0": ("2.1.3", SagaAlgorithm214)}

In the file /usr/share/qgis/python/plugins/processing/algs/saga/SagaAlgorithmProvider.py

I upgraded SAGA from Ubuntu PPA https://launchpad.net/~johanvdw/+archive/ubuntu/saga-gis. Using the following command:

$ sudo apt-add-repository ppa:johanvdw/saga-gis
$ sudo apt-get update
$ sudo apt-get install saga

Which installed the latest version of SAGA GIS version 2.1.4

  • sadly not up to Wily (15.10) as of 17/12/2015
    – dez93_2000
    Commented Dec 17, 2015 at 21:47
  • This was useful information. On 14.04, Saga (2.2) was installed, and was recognised by Processing (2.10.3) in QGIS (2.8.5). But I have tried a couple of Saga algorithms, and they all give me "Segmentation fault (core dumped)". Commented Jan 18, 2016 at 10:55

While running running SAGA 2.2.0 in QGIS 2.0 installed on UBUNTU 14.04 error i got is "Missing dependency.This algorithm cannot be run" . As still i have installed SAGA and checked through console by running saga_cmd. The issue was resolved using following

Go to Processing->Options and Configuration

Click on Providers->SAGA

Uncheck "Enable SAGA 2.0.8 compatibility"

Hope above will help

  • how did you install saga 2.2? I can only install saga 2.1.4
    – Ariel
    Commented Jul 12, 2015 at 19:53
  • I downloaded saga binary and then installed it
    – osmjit
    Commented Jul 19, 2015 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.