3

I'm exporting an ESRI grid to TIFF format and after that I'm reading this exported raster file into SAGA GIS. However when Saga reads this file in there appears to be an additional row and column in the same file and thus changed raster extent. Also cellsize has got some pseudo decimals (2 m -> 2.0000000000000022 m).

ArcMap (10.1) reports 24000 and 21000 while Saga (2.1.0) reports 24001 and 21001 columns and rows for the same file.

Coordinate system is EUREF FIN TM35.

Update: Saga uses GDAL import grid -module as a default to reading rasters in. If one selects this option from module tree (not by load -> file) there are two options to select:

  select from multiple bands [ ] 
  transformation [ ] 

Under transformation there are different interpolation options, which seem to cause the problem. If none is selected, Saga reads my raster in with correct dimensions, but changes cellsize to 0.5.

Any ideas on this one?

  • I've seen this before. My fix was to go into the geoprocessing environment -> Raster Storage, specfy the extent of the output to be the Same as Input, and do the same for the cell size. Seems like a bit of overkill, but it did resolve my instance of this. – evv_gis Feb 24 '14 at 14:34
  • That would solve it if this would've happened in ArcMap, but it appears the raster corrupts when Saga reads it in. Sorry if I was unclear with this. I just tried to write my workflow. ArcMap shows correct dimensions after export. (This type of error can be produced by snap raster -option in ArcMap, however this is not the case here). There is very little info regarding issues on Saga. So hopefully some one here has clues.. – reima Feb 24 '14 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.