1

I am trying to load a CSV table into Grass with v.in.asciifrom the interface of Qgis 2.0.1 on Windows XP. As the progress bar indicated 74% of the data already loaded, I got the message "System not initialized. Programmer forgot to call G_gisinit().". From that moment on, the loading stops. There is no further error message, the progress bar just gets stuck at 74%.

The exact command was: v.in.ascii input=N:/my_path_here/AREA_NOAS04_17_131004.csv output=t7j format=point "fs=;" skip=1 x=1 y=2 z=9 cat=0

I also tried loading the CSV table into QGis, then importing the resulting vector layer (points) into GRASS with v.in.ogr.qgis, with the exact same problem (same message, loading stops at 74%).

If that helps, I'm using the CSV file contained in the Zip archive at the bottom of this page.

I'm able to load other vector layers from Qgis into GRASS without problems. Might the large size of the dataset (4'128'498 points) be a cause of the problem? I tried to google the error message, but without any helpful results.

Does anyone know what this message means and how I can solve this problem? Thanks a lot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.