3

I'm working on some images taken from a UAV over the course of a year. They are OSGB 1936 projection as is the whole project. Annoyingly they don't quite line up so I am trying to a few of the images using the georeferencer tool.

The control points

The settings

The problem is, is that when I run it, the resulting alignment is miles away.

Where it ends up

You can see from the georeferencing screen that it doesn't need to move much. Every tutorial I've seen assumes that it's a completely new image, i.e. jpg or something, that needs referencing rather than a previously referenced image. Am I going about this the wrong way?

  • Try a different transformation type qgistutorials.com/en/docs/georeferencing_basics.html Also try enter your source points in clockwise direction. 0-7 – Mapperz Feb 24 '14 at 21:32
  • I've tried every transformation type and they all end up roughly the same, i.e. far to the bottom left of the scene. I will try and change the source points, but I don't see how that would make a difference to this issue (I can see how it might with the quality at the end). – Martin Feb 24 '14 at 21:53
  • I've also just tested, and added a jpg image from google maps and it instantly worked. Because the image I already have is a geotiff, is this somehow overriding it? – Martin Feb 24 '14 at 22:13
  • I wonder why srcY is negative, and destY positive. You could try output to a vrt and edit the result with a text editor. – AndreJ Feb 25 '14 at 12:09
  • @AndreJoost I'm glad you noticed that. I've added an image to the answer I submitted. I suspect that it's doing something silly such as not loading up the current registration to it correctly and then applying the new one to that, hence the odd negative values. I've corrected them manually before, and you get something wildly odd. – Martin Feb 25 '14 at 16:28
2

Looks like I've solved it, but it seems a bit of a needless way of having to do it. What I did was wipe the registration data by converting the geotiff to a geotiff without the data and then re-did it. This is the command and then I went through the usual process of registering the image.

gdal_translate original.tif -co PROFILE=BASELINE modified.tif

It's certainly doing something odd though. Notice the cursor coordinates when you load the raster, I think this partially explains why we see the negative srcY values. odd

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.