I have a tab delimited text layer (text file created by excel for Mac) that I have used in QGIS 1.8 without problem.

When I try to add the same layer, from the same text file, in QGIS 2.0 the Add Delimited Text Layer process sees the source file as one huge record. Although field delimitating is correctly recognized, it does not recognize record delimitating.

I have also tried saving the text file from Excel in CSV format (rather than tab-delimited) and get exactly the same result.

I am using "Add delimited text layer" from the layer menu, and not trying to use a plugin.

2 Answers 2


You didn't say anything about your Operating System.

If you are on Windows, I think you need to download a utility like Notepad++. Then edit your csv in Notepad++ and choose Edit > Convert to Windows EOL and save the file.

Then you may repeat the import process. It should be ok for now.

enter image description here

enter image description here


You need to select 'Custom delimiters' and then select Tab, as shown belowenter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.