0

I have a tab delimited text layer (text file created by excel for Mac) that I have used in QGIS 1.8 without problem.

When I try to add the same layer, from the same text file, in QGIS 2.0 the Add Delimited Text Layer process sees the source file as one huge record. Although field delimitation is correctly recognized, it does not recognize record delimitation.

I have also tried saving the text file from excel in CSV format (rather than tab-delimited) and get exactly the same result.

I am using "Add delimited text layer" from the layer menu, and not trying to use a plugin.

Grateful for any suggestions...

1

You didn't said anything about your Operating System.

But, if you are on Windows, I think you need to download a utility like Notepad++. Then edit your csv in Notepad++ and choose Edit > Convert to Windows EOL and save the file.

Then you may repeat the import process. It should be ok for now.

enter image description here

enter image description here

  • OK. I am using Mac OS (10.9.2) – Albert Feb 28 '14 at 9:43
  • Just tried editing the text file (using TextWrangler) and saving it with Windows CRLF and it now works. Many thanks. The odd thing is how come the text import process worked fine with Mac OS style CR in QGIS 1.8, but now requires Windows CRLF in QGIS 2?? – Albert Feb 28 '14 at 9:43
0

You need to select 'Custom delimiters' and then select Tab, as shown belowenter image description here

  • I have been selecting custom delimiters / Tabs as you indicate, however in the data preview window I get all the data as one single record, correctly delimited at each tab.... – Albert Feb 28 '14 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.