0

Is there a generic issue with the QgsPluginLayer class in QGIS 2.0.1? When I take the basic Watermark sample from here: https://github.com/sourcepole/qgis-watermark-plugin

and make a couple of mods so that the plugin runs on 2.0.1 (all that appeared to be required was to add a metadata.txt file) it fails with an error "Could not draw Watermark plugin layer because:" and thats it. It seems like there is a similar issue active with an OpenLayers plugin as reported here: http://hub.qgis.org/issues/8679

but I am working on a plugin using the QgsPluginLayer class which is also now broken so I am wondering whether anyone can suggest a workaround or have any idea about when a fix may be available?

Thanks in advance!

1

The sourcepole watermark plugin is 4 years old. It will surely not include the API changes made for QGIS 2.0.

It seems they have not worked on the plugin anymore, so you have to do it yourself :-(

The error in the openlayers plugin should be solved by now. I don't get those error messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.