1

I am learning how to use ArcHydro and attempting to change the Z Units because I get a warning message saying the Spatial Reference Doesn't Match.

The DEM was in Meters, and I adjusted the Z Unit to 100.

My DEM is in a GCS and when I project it to the same PCS my vector data is in, it puts them in two very different places, even though they are in NC State Plane 3200 FIPS (feet).

If someone can give me a recommendation to fix this, I would greatly appreciate it.

  • 3
    It sounds like you need to define the DEM projection first resources.arcgis.com/en/help/main/10.1/index.html#//… , then project the DEM to State Plane. Just be sure the defined projection is the correct one before projecting the raster. – evv_gis Feb 28 '14 at 17:27
  • The original DEM is projected correctly... Is it possible that I'm entering the incorrect Z Unit value? The original DEM was in Meters, but I want to be able to convert to NC State Plane Feet. – user26133 Feb 28 '14 at 21:57
  • 1
    You can use the Raster Calculator to multiply the raster values by 3.28084 to go from Meters to Feet. If the original DEM is correct, you should be able add both the original DEM and the Vector data to the data frame and on-the-fly projection will place them accurately. If not, the coordinate system for either the DEM or the vector data is incorrect. There really is no other reason for this issue to occur. – evv_gis Feb 28 '14 at 22:10
  • Before I adjusted the Z it was lining up perfectly on the fly. I really appreciate your help. – user26133 Feb 28 '14 at 22:31
  • I can see no reason why this part "My DEM is in a GCS and when I project it to the same PCS my vector data is in, it puts them in two very different places" unless there is something astray with that part of the procedure. I think you should research/ask separately about why you are getting an unexpected Coordinate System warning in a procedure that you should be able to document clearly. – PolyGeo Mar 1 '14 at 22:54
1

Alright, after your last comment I believe this should work for you.

Take your original DEM (without the altered Z, unprojected GCS).

If you want the height measurements to be in feet, use the Raster Calculator, multiply the raster by 3.28084 (this will convert the values from meter to feet).

If you want to project the raster to your PCS you can do so now. There is no other alteration needed. Projecting the raster will not alter the DEM values unless you change something in the geoprocessing options before running the tool.

  • What about the original Z Unit warning I was getting from ArcHydro? – user26133 Feb 28 '14 at 23:17
  • The error message is basically stating the current data frame is using a different spatial reference than your raster. Most likely, the data frame is using your vector data PCS (assuming you added your vector data first). After you reproject your raster, create a new document, then add your new DEM and vector data. You should not see this message. If you do, you did not reproject to the same PCS as the vector data. – evv_gis Mar 3 '14 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.