5

I have problem with QGIS 2.0.1. Everytime I run tool from SAGA or GRASS, I get exactly the same error, for example:

Oooops! The following output layers could not be open
Channel Network: /tmp/processing/7efeeab66b224094b23a2701a4fe30ca/CHNLNTWRK.tif
Channel Direction: /tmp/processing/34adb5dd62cb4273981f023aab6b6ded/CHNLROUTE.tif
Channel Network: /tmp/processing/eadce7c1d82e47f1a50dc1c91fd53125/SHAPES.shp
The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm
Checking the log information might help you see why those layers were not created as expected
This algorithm requires SAGA to be run. A test to check if SAGA is correctly installed and configured in your system has been performed, with the following result:
SAGA seems to be correctly installed and configured

Im running QGIS on Linux Mint 64 bit, Windows Vista 32 bit and Windows 7 32 bit, but the problem is exactly the same (even with QGIS 1.8). I have unchecked "Enable SAGA 2.0.8. compatibility" and set the right route. I have tried completly reinstall everything (including cleaning libraries) and I've tried to install QGIS on brand new installation of Linux Mint with same result.

It seems, that compute is running (full load of CPU core for a while - the bigger the layers are, the longer it takes till it stop with error) and log is running, but after stucking I can only close whole window. Temporary folders are created, but there is nothing in then. I have tried to set "hard" route for the result, but it didnt work either.

For me it looks like everything is right except writing down an output, but probably I'm wrong. I've found plenty of similar problems solved by unchecking "Enable SAGA compatibility" or reinstalling SAGA/QGIS, but nothing worked for me. Can anybody help me?


EDIT 03/04/2014 21:24 UTC

Během vykonávání Python kódu se objevila chyba:

Traceback (most recent call last):
  File "/usr/share/qgis/python/plugins/processing/ProcessingPlugin.py", line 142, in openHistory
    dlg = HistoryDialog()
  File "/usr/share/qgis/python/plugins/processing/gui/HistoryDialog.py", line 57, in __init__
    self.fillTree()
  File "/usr/share/qgis/python/plugins/processing/gui/HistoryDialog.py", line 65, in fillTree
    elements = ProcessingLog.getLogEntries()
  File "/usr/share/qgis/python/plugins/processing/core/ProcessingLog.py", line 90, in getLogEntries
    lines = tail(ProcessingLog.logFilename())
  File "/usr/share/qgis/python/plugins/processing/core/ProcessingLog.py", line 256, in tail
    return Tailer(file).tail(lines)
  File "/usr/share/qgis/python/plugins/processing/core/ProcessingLog.py", line 240, in tail
    if not self.seek_line():
  File "/usr/share/qgis/python/plugins/processing/core/ProcessingLog.py", line 201, in seek_line
    bytes_read, read_str = self.read(read_size)
  File "/usr/share/qgis/python/plugins/processing/core/ProcessingLog.py", line 179, in read
    read_str = self.file.read(read_size)
  File "/usr/lib/python2.7/codecs.py", line 671, in read
    return self.reader.read(size)
  File "/usr/lib/python2.7/codecs.py", line 477, in read
    newchars, decodedbytes = self.decode(data, self.errors)
UnicodeDecodeError: 'utf8' codec can't decode byte 0x9a in position 0: invalid start byte

Verze Pythonu:
2.7.4 (default, Sep 26 2013, 03:23:21) 
[GCC 4.7.3]


QGIS verze:
2.0.1-Dufour Dufour, exported

Python cesta: ['/usr/share/qgis/python/plugins/processing', '/usr/share/qgis/python', '/home/hanbanaroda/.qgis2/python', '/home/hanbanaroda/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/pymodules/python2.7', '/usr/lib/python2.7/dist-packages/ubuntu-sso-client', '/usr/lib/python2.7/dist-packages/wx-2.8-gtk2-unicode', '/usr/share/qgis/python/plugins/fTools/tools', '/media/hanbanaroda/A80C5D840C5D4F06/\xc5\xa0kola/Ostatn\xc3\xad/QGIS']

"Během vykonávání Python kódu se objevila chyba:" = During processing Python code an error appeared, "verze" = version

  • "Checking the log information might help you see why those layers were not created as expected"... What do the logs say? – underdark Mar 4 '14 at 19:38
  • I don't know, because the log window shuts down with closing error message. Is there any option how to get log? – Ondrej Berka Mar 4 '14 at 20:12
  • Check the log in the Processing menu – underdark Mar 4 '14 at 20:47
  • I edited main comment. – Ondrej Berka Mar 5 '14 at 18:50
  • UnicodeDecodeError: 'utf8' codec can't decode byte 0x9a in position 0: invalid start byte should give a hint that there is something wrong about the input data. – AndreJ Mar 27 '14 at 10:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.