1

I'm working with the WWF ecoregions, which use the GCS_WGS_1984 geographic coordinate system. I have clipped the ecoregions with a species range (consisting of two polygons), but the new attribute table doesn't tell me the new 'clipped' ecoregion areas.

From reading around it seems I need a projected coordinate system to calculate these new areas. However the attribute table of the ecoregions contain area (km2) as well as shape area. Would these have been calculated using a projected coordinate system? If so, is there a way of finding out which one they used?

I am using ArcGIS 10.1 for Desktop.

  • 1
    Is the file in a geodatabase or is it only a shapefile? What software are you using? – geomatix Mar 5 '14 at 11:40
4

It should not matter whether it is uses a geographic or projected coordinate system. The only way of finding out would be to look at the metadata. It may or may not have come with metadata.

If it is a shapefile, you will have to right click on the title of the field at the top of the table and click on calculate geometry to update the values.

If it is a feature class in a geodatabase, you will have to do the same thing if the field is something besides SHAPE_AREA. Shape area should be updated as edits are made and saved.

If you have a custom field, this will have to be recalculated by using the calculate geometry. Also, note what the map units are set to. It is not necessarily what you name your labels.

  • Sorry I've only just got back, I didn't expect such fast responses. I was using arcmap 10.1 and the file was in a geodatabase. I have projected the ecoregions and range layers to an equal areas projected coordinate system and using the 'calculate geometry' seemed to work after that. The area option was 'disabled' when I tried it before I projected the data for some reason? Many thanks for your help, it was extremely useful! – Louise Mar 11 '14 at 10:22
1

If you are using ArcGIS Desktop:

  1. Open the attribute table.
  2. Right-click at the top of the column (in the field name) and choose "Calculate Geometry..."
  3. Choose Area and Units - km in your case if you want km2.
  • This worked perfectly once I projected the data. I'm just working with South America at the moment so pandas are safe for now. Many thanks for your help. – Louise Mar 11 '14 at 10:23
0

I'll answer on the chance you're using QGIS as I had this issue before.

Open the attribute table, toggle editing and open field calculator. Make sure 'create a new field' is checked and call your new field something like AREA_TRUE. Make sure the output field type is set to decimal number and turn up the precision to 3 to preserve accuracy.

Then in the function list hit the arrow next to geometry and double click $area. Click OK and a new column should have been created showing the true areas of your new polygons.

Remember to save!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.