0

I'm trying to join the values from polygons onto a grid of points. I had this problem solved here by @Underdark , however a few layers weren't working. It seemed they were all British National Grid CRS [EPSG:27700] whereas my project & points CRS is WGS84. The error was:

Oooops! The following output layers could not be open. Result: C:\path\outputname.shp. The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm. Checking the log information might help you see why those layers were not created as expected. This algorithm requires SAGA to be run. A test to check if SAGA is correctly installed and configured in your system has been performed, with the following result: SAGA seems to be correctly installed and configured.

So I tried re-saving the BNG layers as WGS84 as per @Underdark's guide here, the result of which looks fine, however after then adding polygons to points and saving the output as CSV (as I did successfully for the rest), there are no data in the field column.

Can anyone think why this might be? Or what I could do to solve it?

Thanks in advance!

1

Painful that I didn't think to do this earlier:

Convert the POINTS field to BNG and then append the points to that, all projected as BNG. QGis will keep the order of points the same, and pre-prend the CRS (BNG) X/Ys before the Lat/Longs, preserving them for your CSV later.

Still don't know why converting the shapefiles to WGS84 didn't work, but a solution's a solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.