4

I am trying to connect an Oracle 11g database to ArcGIS 10, but it's not working and gives the following error: "Failed to connect to the specified server. Operation Failed."

While I am sure about the inputs, and it's as the following: Database Platform: Oracle Instance: localhost/dbName Username and password are correct.

I tried to connect using sqlplus and it worked properly.

I noticed in some posts that if my Oracle is 64-bit, then I should install Oracle client 32-bit and put its directory as the first one in the PATH directory.

I've done all the above and nothing worked, so if there is anything that I'm missing please let me know. Thanks in advance.

1

so you have a personal oracle on your machine?

The instance should be in the following format:

:port/

where is (as you said) localhost port is the port for oracle listener, which is by default 1521 and database_instance_name is the instance name for your oracle database. I am not sure what the database_isntance_name will be for personal oracle in case you are using personal oracle

If the 32bit client is the first in the "Path" environment variable, then you are using the correct client

0

Starting in 10.1 SP1, it is enough to specify the TNS name in the ArcCatalog connection. Just make sure you have the correct oracle client for 11g, it should be 32bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.